测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
Sample Input
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0
Sample Output
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
代码:
- #include <iostream>
- #include <algorithm>
- #include <stdio.h>
- #include <string.h>
- using namespace std;
- struct Student
- {
- string name;
- int num;
- int score;
- }N[100010];
- bool cmp1(Student a,Student b)
- {
- return a.num<b.num;
- }
- bool cmp2(Student a,Student b)
- {
- if(a.name==b.name) return a.num<b.num;
- else return a.name<b.name;
- }
- bool cmp3(Student a,Student b)
- {
- if(a.score==b.score) return a.num<b.num;
- else return a.score<b.score;
- }
- int main()
- {
- int n,c,i,j;
- j=1;
- while(cin>>n>>c)
- {
- if(n==0) break;
- for(i=0;i<n;i++)
- cin>>N[i].num>>N[i].name>>N[i].score;
- if(c==1) sort(N,N+n,cmp1);
- if(c==2) sort(N,N+n,cmp2);
- if(c==3) sort(N,N+n,cmp3);
- cout<<"Case "<<j++<<":"<<endl;
- for(i=0;i<n;i++)
- {
- printf("%06d ",N[i].num);
- cout<<N[i].name<<" ";
- //printf("%s ",N[i].name);这样输出会提示错误
- printf("%d ",N[i].score);
- }
- }
- return 0;
- }