• HDU Problem 1025 Constructing Roads In JGShining's Kingdom 【LIS】


    Constructing Roads In JGShining's Kingdom

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 23100    Accepted Submission(s): 6591

    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     
    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     
    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     
    Sample Input
    2 1 2 2 1 3 1 2 2 3 3 1
     
    Sample Output
    Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.
     
    Author
    JGShining(极光炫影)
     
    Recommend
    We have carefully selected several similar problems for you:  1024 1081 1074 1078 1080 
     
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    const int INF = 1e9;
    const int MAXN = 500000 + 10;
    int a, b, m, n, ar[MAXN], g[MAXN], dp[MAXN];
    int main() {
        int cnt = 0;
        while (scanf("%d", &n) != EOF) {
            for(int i = 1; i <= n; i++) {
                scanf("%d%d", &a, &b);
                ar[a] = b; g[i] = INF;
            }
            int ans = 0;
            //用数组g记录下标数长度的上升链中最大的元素。
            for (int i = 1; i <= n; i++) {
                //找出在g数组中大于a[i]的第一个元素。
                //把他在数组中的位置带回
                int k = lower_bound(g + 1, g + 1 + n, ar[i]) - g;
                //这个数是严格小于a[i]的最大数,只有接在他后面可以保证连是最长的
                dp[i] = k;
                //每次更新最大值
                g[k] = min(g[k], ar[i]);
                ans = max(ans, dp[i]);
            }
            if (ans == 1)
                printf("Case %d:
    My king, at most %d road can be built.
    
    ", ++cnt, ans);
            else
                printf("Case %d:
    My king, at most %d roads can be built.
    
    ", ++cnt, ans);
        }
        return 0;
    }
     



  • 相关阅读:
    工厂方法模式
    简单工厂模式
    页面滚动动画
    JAVA的深浅拷备
    雷哥架构师课程大钢
    字节与字符串转换
    商城图片懒加载
    MYSQL数据库类型与JAVA类型对应表
    微信支付二码生成办法
    项目中dubbo的标准配置
  • 原文地址:https://www.cnblogs.com/cniwoq/p/6770839.html
Copyright © 2020-2023  润新知