• Uniform Generator


    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form 

    seed(x+1) = [seed(x) + STEP] % MOD 

    where '%' is the modulus operator. 

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 

    InputEach line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000). 
    OutputFor each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line. 
    Sample Input

    3 5
    15 20
    63923 99999

    Sample Output

             3         5    Good Choice
    
            15        20    Bad Choice
    
         63923     99999    Good Choice





    思路 : 水了两晚上的题,差点淹死.......这个题有两种做法,首先就是普通做法,其次就是求两个数最大公约数是不是一;

    第一种方法:
    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
        int s,mod,i;
        while(~scanf("%d%d",&s,&mod))
        {
            int a[100001] = {0},seed=0;
            while(!a[seed]){
                a[seed] = 1;
                seed = (seed+s)%mod;
            }
            for(i=0;i<mod;i++){
               if(a[i] == 0){
                  printf("%10d%10d    Bad Choice
    
    ",s,mod);break;
               }
            }
            if(i==mod){
            	printf("%10d%10d    Good Choice
    
    ",s,mod);
            }
        }
        return 0;
    }
    

      

    第二种方法

    #include <bits/stdc++.h>
    using namespace std;
    int main()
    {
        int step,mod1,t;
        while(scanf("%d%d",&step,&mod1)==2)
        {
            printf("%10d%10d",step,mod1);
            while(mod1)
            {
                t = step%mod1;
                step = mod1;
                mod1 = t;
            }
            printf("    %s
    
    ",step == 1? "Good Choice":"Bad Choice");
        }
        return 0;
    }
    

      欢迎批评指正。

  • 相关阅读:
    Android Studio 常用快捷键以及设置
    GitHub windows客户端拉代码和提交代码
    Android Studio + gradle多渠道打包
    Android sdk 镜像服务器资源
    Rikka with Graph(联通图取边,暴力)
    Rikka with Chess(规律)
    Largest Submatrix(动态规划)
    City Game(动态规划)
    Largest Rectangle in a Histogram(最大矩形面积,动态规划思想)
    How many ways(记忆化搜索)
  • 原文地址:https://www.cnblogs.com/clb123/p/10135016.html
Copyright © 2020-2023  润新知