• PAT(A) 1027. Colors in Mars (20)


    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output

    For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

    Sample Input

    15 43 71
    

    Sample Output

    #123456
    
    #include <cstdio>
    /*
    给定三个[0, 168]范围的十进制数,将他们转换为13进制后按顺序输出
    */
    
    //划重点:建立0~13与'1'~'9','A','B','C'的映射
    char radix[13]={'0', '1', '2', '3', '4', '5','6', '7', '8', '9', 'A', 'B', 'C'};
    
    int main()
    {
        int a, b, c;
        scanf("%d%d%d", &a, &b, &c);
    
        printf("#");
        printf("%c%c", radix[a/13], radix[a%13]);
        printf("%c%c", radix[b/13], radix[b%13]);
        printf("%c%c", radix[c/13], radix[c%13]);
    
        return 0;
    }
  • 相关阅读:
    Openjudge NOI题库 ch0111/01 查找最近的元素
    Openjudge NOI题库 ch0111/07 和为给定数
    Openjudge NOI题库 ch0111/08 不重复地输出数
    Openjudge NOI题库 ch0111/10 河中跳房子|NOIP2015 day2 stone
    Openjudge NOI题库 ch0111/t1776 木材加工
    SRM 508(2-1000pt)
    SRM 507(2-1000pt)
    SRM 504.5(2-1000pt)
    最小生成树专题总结
    SRM 506(2-1000pt)
  • 原文地址:https://www.cnblogs.com/claremore/p/6548256.html
Copyright © 2020-2023  润新知