• PAT(A) 1009. Product of Polynomials (25)


    This time, you are supposed to find A*B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

    Output Specification:

    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

    Sample Input

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output

    3 3 3.6 2 6.0 1 1.6
    
    #include <cstdio>
    
    const int MAXN=2005;
    double poly[MAXN]={};   //多项式系数全都初始化为0
    double poly2[MAXN]={};
    
    int main()
    {
        int k, exp, cnt=0, exp2;
        double coef, coef2;
        scanf("%d", &k);
        for(int i=0; i<k; i++){
            scanf("%d%lf", &exp, &coef);
            poly[exp] += coef;
        }
        //输入第二个多项式的相关数据
        scanf("%d", &k);
        for(int i=0; i<k; i++){
            scanf("%d%lf", &exp, &coef);
            for(int i=0; i<MAXN; i++){
                if(poly[i]!=0.0){
                    coef2=coef*poly[i];
                    exp2=exp+i;
                    poly2[exp2] += coef2;
                }
            }
        }
        for(int i=0; i<MAXN; i++){
            if(poly2[i]!=0)
                cnt++;
        }
        printf("%d", cnt);
        for(int i=MAXN-1; i>=0; i--){
            if(poly2[i]!=0)
                printf(" %d %.1lf", i, poly2[i]);
        }
        return 0;
    }
  • 相关阅读:
    美女检测器
    汉字动画程序的原理
    值类型不是值类型(ValueType is NOT a Value Type):闲谈.Net类型
    PowerShell 简介
    Visual Studio 2012 RC 发布
    使用 MvcMiniProfiler 监控EF 4.1 with MySQL Provider
    NuGet安装及简单使用
    发布自己的NuGet程序
    Qizmt 单机及分布式部署注意事项
    JDynamic :支持Json反序列化为Dynamic对象
  • 原文地址:https://www.cnblogs.com/claremore/p/6547959.html
Copyright © 2020-2023  润新知