• HUST 1010 The Minimum Length


    1010 - The Minimum Length

    Time Limit: 1s Memory Limit: 128MB

    Submissions: 1382 Solved: 519
    Description
    There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A.For example, A="abcdefg". I got abcdefgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
    Input
    Multiply Test Cases.For each line there is a string B which contains only lowercase and uppercase charactors.The length of B is no more than 1,000,000.
    Output
    For each line, output an integer, as described above.
    Sample Input
    bcabcab
    efgabcdefgabcde
    
    Sample Output
    3
    7
    


    这个题目是给定一个由一段字符串A重复组成的字符串B的一部分,且至少包含一个字符串A,求出那个串A的长度

    这个题目再次彰显KMP的强大。。。

    因为是至少包含一个完整的A,所以开头第一个字母与后面组成的一个串长为要求的串A的长度的序列一定与A是同构的,那么由KMP算法求得的第m+1位的那个字符的next值与给出的字符串总长的差一定是这个要求的串A的长度。


    代码如下:

    /*************************************************************************
    	> File Name: The_Minimum_Length.cpp
    	> Author: Zhanghaoran
    	> Mail: chilumanxi@xiyoulinux.org
    	> Created Time: Wed 25 Nov 2015 12:17:00 AM CST
     ************************************************************************/
    
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    
    using namespace std;
    int Max = 0;
    void preKmp(char x[], int m, int kmp_Next[]){
        int i, j;
        j = -1;
        kmp_Next[0] = -1;
        i = 0;
        while(i < m){
            if(j == -1 || x[i] == x[j]){
                kmp_Next[++i] = ++ j;
            }
            else
                j = kmp_Next[j];
            if(Max < j)
                Max = j;
        }
        kmp_Next[0] = 0;
    }
    int nexti[1000010];
    char a[1000010];
    int main(void){
        while(~scanf("%s", a)){
            preKmp(a, strlen(a), nexti);
            cout << strlen(a) - nexti[strlen(a)] << endl;
            Max = 0;
        }
    }


  • 相关阅读:
    如何使用腾讯位置服务地图选点组件?
    vue使用腾讯位置服务获取当前位置示例
    腾讯位置服务地址搜索&marker标记demo
    如何优雅接入腾讯地图SDK公交路线规划2?
    如何优雅接入腾讯地图SDK公交路线规划?
    地图SDK自定义路况和字体示例
    腾讯地图SDK自定义地图和路况示例
    手把手教你实现3D地图的定时高亮和点击事件
    vue实现坐标拾取器功能demo
    jmeter之安装ant
  • 原文地址:https://www.cnblogs.com/chilumanxi/p/5136052.html
Copyright © 2020-2023  润新知