• Yukari's Birthday


    Description

    Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time. Though she herself insists that she is a 17-year-old girl.

    To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place ki candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.

    Input

    There are about 10,000 test cases. Process to the end of file.

    Each test consists of only an integer 18 ≤ n ≤ 1012.

    Output

    For each test case, output r and k.

    Sample Input

    18
    111
    1111
    

    Sample Output

    1 17
    2 10
    3 10

    枚举+二分

    刚开始还以为是线性规划……到网上搜了下才知道是枚举+二分

    /*
    pow(int, double) 用于long long 的时候可能会出错,比如爆掉。
    所以要重新写一个计算long long 的pow函数
    */
    #include <iostream>
    #include <cmath>
    using namespace std;
    
    long long powForLL(long long a, int b)    //long long 的pow函数
    {
        long long ans = 1;
        
        for (int i = 0; i < b; ++i)
            ans *= a;
        
        return ans;
    }
    
    int main()
    {
        long long n, r, k;
        
        while (cin >> n)
        {
            r = 1, k = n-1;
            
            for (int i = 2; i <= 45; ++i) //why 45?
            {
                long long ll = 2, rr = pow(n, 1.0/i), mm;    // ll rr mm都是关于k的 i是关于r的 
                
                while (ll <= rr)
                {
                    mm = (long long)(ll+rr)/2;
                    
                    long long ans = (mm-powForLL(mm,(double)i+1))/(1-mm);//等比数列求和公式别说你不懂 
                    
                    if (ans == n || ans == n-1)    //中间不插蜡烛为n,插就n-1 
                    {
                        if (mm*i < r*k)
                        {
                            r = i, k = mm;
                        }
                        break;
                    }
                    else if (ans > n)
                    {
                        rr = mm-1;
                    }
                    else
                    {
                        ll = mm+1;
                    }
                }
            }
            
            cout << r << ' ' << k << endl;
        }
    }
    View Code
  • 相关阅读:
    Django的templates(模板)
    Django的urls(路由)
    Markdown中实现折叠代码块
    图片上传2
    Comparator 排序
    Serializable 序列化为文件
    统计连续签到的方法
    Serializable 序列化为字符串 base64
    Serializable 序列化使用限制
    Serializable 剔除某些不想保存的字段 transient
  • 原文地址:https://www.cnblogs.com/chenyg32/p/3136789.html
Copyright © 2020-2023  润新知