• poj 1012(约瑟夫环)


    int g[15]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};

    打表比较好吧,13的数据量。

    如果用循环链表模拟暴力要跑很多时间才能搞定。 根据这题只看前k个和后k个。  第一次到s%2*k,  那么第二次则到  (s+s%(2*k-1))%(2*k-1) ,如此递推只需k的时间就可以A了。

    Joseph
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 43659   Accepted: 16425

    Description

    The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

    Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

    Input

    The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

    Output

    The output file will consist of separate lines containing m corresponding to k in the input file.

    Sample Input

    3
    4
    0
    

    Sample Output

    5
    30
    
    

    Source

    #include <stdio.h>
    #include <string.h>
    
    int g[15]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};
    /*
    int mark[30];
    int l[30],r[30];
    
    int main()
    {
        for(int k=1;k<=13;k++)
        {
            for(int j=k; ;j++)
            {
                int s=0,ts;
                int flag=0;
                for(int i=2*k;i>k;i--)
                {
                    s=(s+(j%i))%i;
                    if(s<=k-1) 
                    {
                        flag=1;
                        break;
                    }
                }
    
                if(flag==0)
                {
                    printf("%d,",j+1);
                    break;
                }
            }
    
        }
        return 0;
    }*/
    
    int main()
    {
        int n;
        while(scanf("%d",&n)&&n)
            printf("%d\n",g[n]);
        return 0;
    }
  • 相关阅读:
    Javascript 与 c# 数据加密互通 DEC
    Auto.js 隐藏日志信息、定时器
    Auto.js 检测开启无障碍
    Auto.js 初学碰到的坑
    SmartAssembly 汉化说明
    espcms 表结构说明
    处理器调度
    进程死锁与避免
    并发程序设计
    Mysql性能调优
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/3050800.html
Copyright © 2020-2023  润新知