• poj 3714 (最近点对)


    看了算法导论, 发现了一种求最近点对的高效方法, 就是在合并操作时只找每个点(已经按y排好序)以下的6个点 。 这样就可以使复杂度变为O(n*logn*logn) ,但是这题我却没有发现有这个性质,用的是一种比较好的优化。

    Raid
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 6865   Accepted: 2026

    Description

    After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

    The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

    Input

    The first line is a integer T representing the number of test cases.
    Each test case begins with an integer N (1 ≤ N ≤ 100000).
    The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
    The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

    Output

    For each test case output the minimum distance with precision of three decimal placed in a separate line.

    Sample Input

    2
    4
    0 0
    0 1
    1 0
    1 1
    2 2
    2 3
    3 2
    3 3
    4
    0 0
    0 0
    0 0
    0 0
    0 0
    0 0
    0 0
    0 0

    Sample Output

    1.414
    0.000

    Source

    #include <stdio.h>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    #define N 200100
    #define INF 0x3ffffffffff
    
    struct node
    {
        double x,y;
        int flag;
    }g[N];
    
    int n;
    int cnt;
    int cnt1,cnt2;
    node g1[N],g2[N];
    
    int cmp(node t,node t1)
    {
        if(t.x!=t1.x) return t.x<t1.x;
        return t.y<t1.y;
    }
    
    double fuc(node t,node t1)
    {
        return sqrt((t.x-t1.x)*(t.x-t1.x)+(t.y-t1.y)*(t.y-t1.y));
    }
    
    double dfs(int b,int d)
    {
        cnt1=0,cnt2=0;
        //node g1[N],g2[N];
        for(int i=b;i<=d;i++)
        {
            if(g[i].flag==1) g1[cnt1++]=g[i];
            else g2[cnt2++]=g[i];
        }
        if(cnt1==0||cnt2==0) return INF;
        double tmp1,tmp2;
        int mid=(b+d)/2;
        tmp1=dfs(b,mid);
        tmp2=dfs(mid+1,d);
        double mi=min(tmp1,tmp2);
        int t1=0,t2=0;
        cnt1=0; cnt2=0;
        for(int i=b;i<=d;i++)
        {
            if(g[i].flag==1) g1[cnt1++]=g[i];
            else g2[cnt2++]=g[i];
        }
        for(int i=0;i<cnt1;i++)
        {
            if(abs(g1[i].x-g[mid].x)<mi)
            {
                g1[t1++]=g1[i];
            }
            else break;
        }
        for(int i=0;i<cnt2;i++)
        {
            if(abs(g2[i].x-g[mid].x)<mi)
            {
                g2[t2++]=g2[i];
            }
            else break;
        }
        //sort(g1,g1);
        for(int i=0;i<t1;i++)
        {
            for(int j=0;j<t2;j++)
            {
                if(fuc(g1[i],g2[j])<mi)
                    mi=fuc(g1[i],g2[j]);
            }
        }
        return mi;
    }
    
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            cnt=0;
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
            {
                scanf("%lf%lf",&g[cnt].x,&g[cnt].y);
                g[cnt].flag=1;
                cnt++;
            }
            for(int i=1;i<=n;i++)
            {
                scanf("%lf%lf",&g[cnt].x,&g[cnt].y);
                g[cnt].flag=2;
                cnt++;
            }
            double tmp;
            sort(g,g+cnt,cmp);
            tmp=dfs(0,cnt-1);
            if(tmp!=INF) 
            printf("%.3lf\n",tmp);
            else printf("0\n");
        }    
        return 0;
    }
  • 相关阅读:
    二分查找法
    AES算法工具类
    SHA加密算法工具类
    使用SQL创建唯一索引
    springboot 启动类CommandLineRunner(转载)
    MD5加密算法工具类
    Android 通过Socket 和服务器通讯
    android 网络连接判断
    android 文件上传,中文utf-8编码
    github打不开问题
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/2990734.html
Copyright © 2020-2023  润新知