• HUAS Summer Trainning #3~L


    Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input

    The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

    Output

    are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0

    Sample Output

    0
    1
    2
    2
    解题思路:题目意思是输入一个m*n的字符矩阵,统计字符‘@’组成多少个八连块。如果两个字符‘@’所在的格子相邻(横、竖或者对角线方向),就说它们属于同一个八连块。这种题目一般可以用DFS来求它的连同块,从每个‘@’格子出发,递归遍历它周围的‘@’格子。每次访问一个格子时就给它写上一个“连通分量编号”,这样就可以在访问之前检查它是否已经有了编号,从而避免同一个格子访问多次。
    程序代码:

    #include <cstdio>
    #include <cstring>
    const int maxn=100+5;
    char pic[maxn][maxn];
    int m,n,idx[maxn][maxn];

    void dfs(int r,int c,int id)
    {
     if(r<0||r>=m||c<0||c>=n)  return;
      
     if(idx[r][c]>0||pic[r][c]!='@')  return;
      idx[r][c]=id;
     
      for(int dr=-1;dr<=1;dr++)
      for(int dc=-1;dc<=1;dc++)
       if(dr!=0||dc!=0) 
        dfs(r+dr,c+dc,id);
     
    }

    int main()
    {
    while(scanf("%d%d",&m,&n)==2&&m&&n)
    {
     for(int k=0;k<m;k++)
     scanf("%s",pic[k]);
     memset(idx,0,sizeof(idx));
     int cnt=0;
     for(int i=0;i<m;i++)
      for(int j=0;j<n;j++)
       if(idx[i][j]==0&&pic[i][j]=='@')
        dfs(i,j,++cnt);
       printf("%d ",cnt);

    return 0;
    }

  • 相关阅读:
    vue-router 路由拦截 beforeEach 添加静态路由 与 动态添加路由
    elementUI el-upload 根据上传的图片高度,进行自适应宽度
    vue 中 字符串分两行显示
    MySQL中的<=>
    Spring mvc再启动时候会打印项里面的所有路径
    一次解决前后台交互问题
    数据库表分区,分表
    支付宝接口
    打印js中一个对象的所有属性的值
    var
  • 原文地址:https://www.cnblogs.com/chenchunhui/p/4693124.html
Copyright © 2020-2023  润新知