• Poj 2421 Constructing Roads


    Description

    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

    Input

    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

    Output

    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

    Sample Input

    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
    

    Sample Output

    179


    屠龙宝刀点击就送
    这道题,我们只需要把原本已经连好的边把权值当成0,那么我们在进行最小生成树算法的时候,总会优先把这些边连上。
     
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<cmath>
    #define maxn 1000010
    #define maxm 1000
    using namespace std;
    int n,q,a,b,ans,fa[maxn],s,cnt,vis[maxm][maxm],make[maxm][maxm];
    struct Edge{
        int x,y,dis;
    }edge[maxn];
    int found(int x){ return x==fa[x]?x:found(fa[x]);}
    bool cmp(Edge a,Edge b){ return a.dis<b.dis; }
    
    int main()
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&s);
                make[j][i]=true;
                if(!make[i][j])
                {
                    edge[++cnt].x=i;
                    edge[cnt].y=j;
                    edge[cnt].dis=s;
                }
            }
        scanf("%d",&q);
        for(int i=1;i<=q;i++)
        {
            scanf("%d%d",&a,&b);
            for(int k=1;k<=cnt;k++)
            {
                if(edge[k].x==a&&edge[k].y==b) edge[k].dis=0;
            }
        }
        sort(edge+1,edge+cnt+1,cmp);
        for(int i=1;i<=n;i++) fa[i]=i;
        for(int i=1;i<=cnt;i++)
        {
            int fx=found(edge[i].x),fy=found(edge[i].y);
            if(fx!=fy)
            {
                fa[fx]=fy;
                ans+=edge[i].dis;
            }
        }
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    精确计算微信小程序scrollview高度,全机型适配
    精确计算微信小程序scrollview高度,全机型适配
    七牛云赵之健:多维度融合赋能视频 AI 的实践
    javaweb学习总结(四十)——编写自己的JDBC框架
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    深度学习入门笔记(十三):批归一化(Batch Normalization)
    4G EPS 中的 Control Plane
    4G EPS 中建立 eNB 与 MME 之间的 S1 连接
  • 原文地址:https://www.cnblogs.com/chen74123/p/6842565.html
Copyright © 2020-2023  润新知