• 1006. Sign In and Sign Out


    1006. Sign In and Sign Out (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:
    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
    Sample Output:
    SC3021234 CS301133
    import java.util.Arrays;
    import java.util.Comparator;
    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner in=new Scanner(System.in);
            int m=in.nextInt();
            in.nextLine();
            String sname = null,stime = null,ename = null,etime = null;
            for(int i=0;i<m;i++){
                String s[]=in.nextLine().split(" ");
                if(i==0){
                    sname=s[0];
                    ename=s[0];
                    stime=s[1];
                    etime=s[2];
                }
                else{
                    if(s[1].compareTo(stime)<0){
                        sname=s[0];
                        stime=s[1];
                    }
                    if(s[2].compareTo(etime)>0){
                        ename=s[0];
                        etime=s[2];
                    }
                }
            }
            System.out.println(sname+" "+ename);
        }
    }

    参考

    http://blog.csdn.net/qq_26437925/article/details/49837763

  • 相关阅读:
    项目总结
    个人博客
    个人博客
    个人博客
    个人博客
    个人博客
    个人博客
    个人博客
    个人博客
    浅谈Vue与swiper轮播图框架结合小案例
  • 原文地址:https://www.cnblogs.com/chen20135517/p/7707412.html
Copyright © 2020-2023  润新知