• 1002 A+B for Polynomials (25 分)


    This time, you are supposed to find A+B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

    N1 aN1 N2 aN2 ... NK aNK

    where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1K10,0NK<<N2<N11000.

    Output Specification:

    For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5

    Sample Output:

    3 2 1.5 1 2.9 0 3.2

    Submit:

    #include <stdio.h>
    //多项式的和即:2.4x^1 + 3.2x^0 + 1.5x^2 + 0.5x^1 = 1.5x^2 + 2.9x^1 + 3.2
    //a[exp] = coe; 下标表示指数,数组值表示系数
    int main() {
        float a[1001] = {0};
        int i,m,n,exp,k=0;
        float coe;//系数
        scanf("%d",&m);
        for (i=0;i<m;i++) {
            scanf("%d %f",&exp,&coe);
            a[exp] += coe;
        }
        scanf("%d",&n);
        for (i=0;i<n;i++) {
            scanf("%d %f",&exp,&coe);
            a[exp] += coe;
        }
        for (i=0;i<1001;i++) 
            if (a[i] != 0.0) k++;
        printf("%d",k);
        for (i=1000;i>=0;i--) {
            if (a[i] != 0.0) printf(" %d %.1f",i,a[i]);
        }
        return 0;
    }

    参考:

    柳婼-https://blog.csdn.net/liuchuo/article/details/54561626

    昵称五个字-https://blog.csdn.net/a617976080/article/details/89676670

  • 相关阅读:
    A1151 LCA in a Binary Tree (30分)
    A1150 Travelling Salesman Problem (25分)
    A1069 The Black Hole of Numbers (20分)
    A1149 Dangerous Goods Packaging (25分)
    A1148 Werewolf
    A1147 Heaps (30分)
    Ubuntu下git,gitlab团队协作
    如何查看JDK_API 2019.2.23
    linux_day1 (腾老师)2019年3月25日18:11:43(CentOs)
    jpa_缓存
  • 原文地址:https://www.cnblogs.com/cgy-home/p/15100161.html
Copyright © 2020-2023  润新知