• Crazy Search(hash)


    Crazy Search

    Description:
    Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
    Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.
    As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.
    Input:
    The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
    Output:
    The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
    Sample Input:
    3 4
    daababac
    Sample Output:
    5
    题目大意:
    求一个字符串s的所有长度为n的子串,其中原串的不同字符个数为nc.
    思路:
    因为一共有nc种字符。所以每种字符映射一个数字,那么就可以把长度为n的字串看做nc进制的数,然后hash就可以啦。

    #include<iostream>
    #include<cstring>
    using namespace std;
    int n,nc,sum,tot,ans,m[257];
    char s[1000000];
    bool hash[16000005];
    int main()
    {
        cin>>n>>nc>>s;
        for(int i=0;''!=s[i];i++)
        {
            if(!m[s[i]])
            m[s[i]]=++tot;
            if(tot==nc) break;
        }
        int len=strlen(s);
        for(int i=0;i<=len-n;i++)
        {
            sum=0;
            for(int j=0;j<n;j++)
            sum=sum*nc+m[s[i+j]]-1;
            if(!hash[sum])
            hash[sum]=true,ans++;
        }
        cout<<ans;
        return 0;
    }
  • 相关阅读:
    C语言判断字符串是否是 hex string的代码
    红米手机使用应用沙盒一键修改sdk信息
    Python illustrating Downhill simplex method for minimizing the user-supplied scalar function的代码
    荣耀5.0以上手机(亲测有效)激活xposed框架的经验
    java压缩指定目录下的所有文件和文件夹的代码
    荣耀7.0系统手机最简单激活Xposed框架的步骤
    小米平板7.0系统如何不root激活Xposed框架的方法
    安装与配置Flutter开发环境
    Spring Boot 2
    Flutter介绍
  • 原文地址:https://www.cnblogs.com/cax1165/p/6070954.html
Copyright © 2020-2023  润新知