• UVa 1548 Circular Sequence (字符串处理)


    Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

    Status

    Description

    Download as PDF

    Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence ``CGAGTCAGCT", that is, the last symbol ``T" in ``CGAGTCAGCT" is connected to the first symbol ``C". We always read a circular sequence in the clockwise direction.

    epsfbox{p3225.eps}

    Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

    Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

    Input 

    The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, A, C, G and T, are allowed. Each sequence has length at least 2 and at most 100.

    Output 

    Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

    The following shows sample input and output for two test cases.

    Sample Input 

    2                                     
    CGAGTCAGCT                            
    CTCC
    

    Sample Output 

    AGCTCGAGTC 
    CCCT
    
    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    #define maxn 105
    using namespace std;
    
    int less1(const char *s ,int p,int q){
        int n = strlen(s);
        for(int i = 0; i < n;i++){
            if(s[(q+i)%n] != s[(p+i)%n])
                return s[(p+i)%n] < s[(q+i)%n];
        }
        return 0;
    }
    
    int main(){
        int T;
        while(cin>>T){
            while(T--){
                char s[maxn];
                cin>>s;
                int ans = 0;
                int len = strlen(s);
                for(int i = 1; i < len ; i++){
                    if(less1(s,i,ans)) ans = i;
                }
                for(int i = 0; i < len; i++){
                    cout<<s[(ans+i)%len];
                }
                cout<<endl;
            }
        }
    }
    
  • 相关阅读:
    教你用笔记本充当无线路由,wifi上网了!!!
    SQL重复记录查询
    ==、object.Equals()、object.ReferenceEquals()
    SeriesChartType
    容易被忽视的装箱问题
    [转]Anonymous type and implicit type
    as、is、GetType()
    [转]dataGridView控件DateTime列插入DateTimePicker
    .NET(C#):理解值类型/引用类型,装箱/拆箱,Object类
    通过其轴标签沿 X 轴对齐不同系列中的数据点
  • 原文地址:https://www.cnblogs.com/caterpillarofharvard/p/4231809.html
Copyright © 2020-2023  润新知