• 洛谷 P2853 [USACO06DEC]牛的野餐Cow Picnic


    题目描述

    The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

    The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

    K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?

    输入输出格式

    输入格式:

     

    Line 1: Three space-separated integers, respectively: K, N, and M

    Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing.

    Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

     

    输出格式:

     

    Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

     

    输入输出样例

    输入样例#1: 复制
    2 4 4
    2
    3
    1 2
    1 4
    2 3
    3 4
    输出样例#1: 复制
    2

    说明

    The cows can meet in pastures 3 or 4.

    思路:搜索即可,但是不明白深搜为什么会TLE。

    #include<queue>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 1010
    using namespace std;
    int k,n,m,tot,ans;
    int vis[MAXN],num[110],bns[MAXN];
    int to[10010*2],net[10010*2],head[MAXN];
    void add(int u,int v){
        to[++tot]=v;net[tot]=head[u];head[u]=tot;
    }
    void bfs(int x){
        queue<int>que;
        que.push(x);
        while(!que.empty()){
            int now=que.front();
            que.pop();
            for(int i=head[now];i;i=net[i])
                if(!vis[to[i]]){
                    bns[to[i]]++;
                    vis[to[i]]=1;
                    que.push(to[i]);
                }
        }
    }
    int main(){
        scanf("%d%d%d",&k,&n,&m);
        for(int i=1;i<=k;i++)
            scanf("%d",&num[i]);
        for(int i=1;i<=m;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            add(x,y);
        }
        for(int i=1;i<=k;i++){
            bns[num[i]]++;vis[num[i]]=1;
            bfs(num[i]);memset(vis,0,sizeof(vis));
        }
        for(int i=1;i<=n;i++)
            if(bns[i]==k)    ans++;    
        cout<<ans;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    delphi XE8 for android ----一个无意闯入的世界
    不能Ping和telnet的
    syslog-ng内容讲解
    《信息安全系统设计与实现》学习笔记7
    缓冲区溢出实验
    2.3.1测试
    鲲鹏服务器测试
    cat userlist
    需求分析
    《信息安全系统设计与实现》学习笔记5
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8849313.html
Copyright © 2020-2023  润新知