• CF47A Triangular numbers


    题意翻译

    给定一个数n,问你是否存在一个整数i,满足i*(i+1)/2=n。

    若存在,输出"YES",否则输出"NO".

    1<=n<=500

    Translated by @稀神探女

    题目描述

    A triangular number is the number of dots in an equilateral triangle uniformly filled with dots. For example, three dots can be arranged in a triangle; thus three is a triangular number. The nn -th triangular number is the number of dots in a triangle with nndots on a side. . You can learn more about these numbers from Wikipedia (http://en.wikipedia.org/wiki/Triangular\_number).

    Your task is to find out if a given integer is a triangular number.

    输入输出格式

    输入格式:

     

    The first line contains the single number nn ( 1<=n<=5001<=n<=500 ) — the given integer.

     

    输出格式:

     

    If the given integer is a triangular number output YES, otherwise output NO.

     

    输入输出样例

    输入样例#1: 复制
    1
    
    输出样例#1: 复制
    YES
    
    输入样例#2: 复制
    2
    
    输出样例#2: 复制
    NO
    
    输入样例#3: 复制
    3
    
    输出样例#3: 复制
    YES

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n;
    int main(){
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            if(i*i+i==2*n){
                cout<<"YES";
                return 0;
            }
        cout<<"NO";
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    操作文件和目录【TLCL】
    nginx location正则写法
    elasticsearch分词器ik
    mongodb权限管理
    kafka调试遇到的问题
    mysql 安装
    jenkins 安装 + maven + git部署
    FTP服务搭建
    根据终端类型返回不同的访问内容
    上传jar包至nexus
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8442541.html
Copyright © 2020-2023  润新知