• CF914A Perfect Squares


    题意翻译

    给定一组有n个整数的数组a1,a2,…,an.找出这组数中的最大非完全平方数。 完全平方数是指有这样的一个数x,存在整数y,使得x=y^2y2 .

    输入格式

    第一行输入一个单独的整数n(1<=n<=1000 ),n为该组数的数量。 接下来有n个整数,a1,a2,an(-10^6<=a<=10^6) 数据保证至少存在一个整数是非完全平方数。

    题目描述

    Given an array a_{1},a_{2},...,a_{n}a1,a2,...,an of nn integers, find the largest number in the array that is not a perfect square.

    A number xx is said to be a perfect square if there exists an integer yy such that x=y^{2}x=y2 .

    输入输出格式

    输入格式:

     

    The first line contains a single integer nn ( 1<=n<=10001<=n<=1000 ) — the number of elements in the array.

    The second line contains nn integers a_{1},a_{2},...,a_{n}a1,a2,...,an ( -10^{6}<=a_{i}<=10^{6}106<=ai<=106 ) — the elements of the array.

    It is guaranteed that at least one element of the array is not a perfect square.

     

    输出格式:

     

    Print the largest number in the array which is not a perfect square. It is guaranteed that an answer always exists.

     

    输入输出样例

    输入样例#1: 复制
    2
    4 2
    
    输出样例#1: 复制
    2
    
    输入样例#2: 复制
    8
    1 2 4 8 16 32 64 576
    
    输出样例#2: 复制
    32
    

    说明

    In the first sample case, 44 is a perfect square, so the largest number in the array that is not a perfect square is 22 .

    #include<cmath>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 1001
    using namespace std;
    int n;
    int num[MAXN];
    int main(){
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        sort(num+1,num+1+n);
        for(int i=n;i>=1;i--){
            int k=sqrt(num[i]);
            if(k*k!=num[i]){
                cout<<num[i];
                return 0;
            }
        }
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    maven打包将依赖和配置外置的配置方式
    AngularJS零碎总结
    Python零碎总结
    win10 平台 elasticsearch 与 elasticsearch-head 的安装
    DDD中的分层架构
    读书有感--------软件的设计原则
    DDD初探
    HTTP could not register URL http://+:86/. 设置VS默认以管理员权限打开
    .net 实战 根据configuration选项生成不同的config文件
    asp.net mvc5轻松实现插件式开发
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8440585.html
Copyright © 2020-2023  润新知