• 洛谷 P3662 [USACO17FEB]Why Did the Cow Cross the Road II S


    题目描述

    The long road through Farmer John's farm has NN crosswalks across it, conveniently numbered 1 ldots N1N (1 leq N leq 100,0001N100,000). To allow cows to cross at these crosswalks, FJ installs electric crossing signals, which light up with a green cow icon when it is ok for the cow to cross, and red otherwise. Unfortunately, a large electrical storm has damaged some of his signals. Given a list of the damaged signals, please compute the minimum number of signals that FJ needs to repair in order for there to exist some contiguous block of at least KK working signals.

    共有N个信号灯,编号为1~N,有B个信号灯损坏,给你它们的编号。

    问,最少修好几个信号灯,可以有K个编号连续的信号灯。

    输入输出格式

    输入格式:

     

    The first line of input contains NN, KK, and BB (1 leq B, K leq N1B,KN). The next BB lines each describe the ID number of a broken signal

     

    输出格式:

     

    Please compute the minimum number of signals that need to be repaired in order for there to be a contiguous block of KKworking signals somewhere along the road.

     

    输入输出样例

    输入样例#1: 复制
    10 6 5
    2
    10
    1
    5
    9
    输出样例#1: 复制
    1

    说明

    感谢@ jlyzxxm1 提供题意简述

    思路:前缀和维护一下即可。

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 100010
    using namespace std;
    int n,k,b;
    int ans=0x7f7f7f7f;
    int vis[MAXN],sum[MAXN];
    int main(){
        scanf("%d%d%d",&n,&k,&b);
        for(int i=1;i<=b;i++){
            int x;
            scanf("%d",&x);
            vis[x]=1;
        }
        for(int i=1;i<=n;i++)    sum[i]+=sum[i-1]+vis[i];
        for(int i=1;i<=n-k+1;i++)    ans=min(ans,sum[i+k-1]-sum[i-1]);
        printf("%d",ans);
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    汉字词组换行
    C#中获取Excel文件的第一个表名
    SQL查找某一条记录的方法
    C#数据库连接字符大全
    整理的asp.net资料!(不得不收藏)
    母版页的优点,及母版页与内容页中相互访问方法
    13范式
    使用 Jackson 树连接线形状
    word2007,取消显示回车符
    三张表之间相互的多对多关系
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8157149.html
Copyright © 2020-2023  润新知