• 洛谷 P2960 [USACO09OCT]Milkweed的入侵Invasion of the Milkweed


    题目描述

    Farmer John has always done his best to keep the pastures full of luscious, delicious healthy grass for the cows. He has lost the battle, though, as the evil milkweed has attained a foothold in the northwest part of his farm.

    The pasture, as usual, is partitioned into a rectilinear grid of height Y (1 <= Y <= 100) and width X (1 <= X <= 100) with (1,1) being in the lower left corner (i.e., arranged as a normal X,Y coordinate grid). The milkweed has initially begun growing at square (Mx,My). Each week the milkweed propagates to all non-rocky squares that surround any square it already occupies, as many as eight more squares (both the rectilinear squares and the diagonals). After only one week in those squares, it is ready to move on to more squares.

    Bessie wants to enjoy all the grass she can before the pastures are taken over by milkweed. She wonders how long it can last. If the milkweed is in square (Mx,My) at time zero, at what time does it complete its invasion of the pasture (which, for the given input data, will always happen)?

    The pasture is described by a picture with '.'s for grass and '*'s for boulders, like this example with X=4 and Y=3:

    .... ..*.

    .**. If the milkweed started in the lower left corner (row=1, column=1), then the map would progress like this:

    .... .... MMM. MMMM MMMM

    ..*. MM*. MM*. MM*M MM*M

    M. M. M. M. M**M

    week 0 1 2 3 4

    The milkweed has taken over the entire field after 4 weeks.

    POINTS: 125

    Farmer John一直努力让他的草地充满鲜美多汁的而又健康的牧草。可惜天不从人愿,他在植物大战人类中败下阵来。邪恶的乳草已经在他的农场的西北部份占领了一片立足之地。

    草地像往常一样,被分割成一个高度为Y(1 <= Y <= 100), 宽度为X(1 <= X <= 100)的直角网格。(1,1)是左下角的格(也就是说坐标排布跟一般的X,Y坐标相同)。乳草一开始占领了格(Mx,My)。每个星期,乳草传播到已被乳草占领的格子四面八方的每一个没有很多石头的格(包括垂直与水平相邻的和对角在线相邻的格)。1周之后,这些新占领的格又可以把乳草传播到更多的格里面了。

    Bessie想要在草地被乳草完全占领之前尽可能的享用所有的牧草。她很好奇到底乳草要多久才能占领整个草地。如果乳草在0时刻处于格(Mx,My),那么会在哪个时刻它们可以完全占领入侵整片草地呢?对给定的数据总是会发生。

    输入输出格式

    输入格式:

     

    • Line 1: Four space-separated integers: X, Y, Mx, and My

    • Lines 2..Y+1: Line y+1 describes row (Y+2-y) of the field with X characters ('.' for grass and '*' for a boulder)

     

    输出格式:

     

    • Line 1: A single integer that is the week number when the milkweed takes over the last remaining non-boulder square of the pasture.

     

    输入输出样例

    输入样例#1: 复制
    4 3 1 1 
    .... 
    ..*. 
    .**. 
    
    输出样例#1: 复制
    4 
    

     思路:搜索。

    #include<queue>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,m,sx,sy,ans;
    char s[101];
    int vis[101][101];
    int map[101][101];
    int dx[8]={-1,-1,-1,0,0,1,1,1};
    int dy[8]={-1,0,1,-1,1,-1,0,1};
    struct nond{
        int x,y,pos;
    }v;
    queue<nond>que;
    int main(){
        scanf("%d%d%d%d",&m,&n,&sy,&sx);
        for(int i=n;i>=1;i--){
            scanf("%s",s);
            for(int j=1;j<=m;j++)
                if(s[j-1]=='*')    map[i][j]=1;
        }
        vis[sx][sy]=1;nond tmp;
        tmp.x=sx,tmp.y=sy;tmp.pos=0;
        que.push(tmp);
        while(!que.empty()){
            nond now=que.front();
            que.pop();
            for(int i=0;i<8;i++){
                nond c;
                c.x=now.x+dx[i];
                c.y=now.y+dy[i];
                c.pos=now.pos+1;
                if(c.x>=1&&c.x<=n&&c.y>=1&&c.y<=m&&!map[c.x][c.y]&&!vis[c.x][c.y]){
                    vis[c.x][c.y]=c.pos;
                    ans=max(ans,vis[c.x][c.y]);
                    que.push(c);
                }
            }
        }
        cout<<ans;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    drawcall优化
    Java基础:动态代理在RPC框架中应用
    ACdream ACfun
    图片压缩之处理小图片压缩策略
    ASP内置对象—Request、Response 、Server、Application 、ObjectContent(一)
    alter
    UltraISO制作U盘启动盘安装Win7/8/10系统攻略
    Libcurl的初步实现tfp上传下载功能
    微信企业号开发:获取AccessToken
    Ubuntu 安装OpenGL
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8092559.html
Copyright © 2020-2023  润新知