• 洛谷 P2958 [USACO09OCT]木瓜的丛林Papaya Jungle


    题目描述

    Bessie has wandered off the farm into the adjoining farmer's land. He raises delicious papaya fruit, which is a delicacy for cows. The papaya jungle is partitioned into a grid of squares with R rows and C columns (1 <= R <= 40, 1 <= C <= 40), as is popular in Wisconsin. Bessie can travel from a given square to any existing adjacent square whose route is parallel to the X or Y axis. So in the

    following diagram, if Bessie is at the square labeled 'B', she can travel to any of the squares labeled 'T':

    .T. TBT .T. Bessie always starts out by munching the papayas in square

    (row=1,col=1). After she's done with one square, Bessie always uses her trusty binoculars to count the low-hanging fruit in each of the adjacent squares. She then always moves to the square with the most visible uneaten fruit (a square that happily is always unique).

    Sooner or later, following this rule, Bessie always ends up in square (R,C) and eats the fruit there.

    Given the dimensions of the papaya jungle and the amount of fruit F_ij in each square (1 <= F_ij <= 100), determine the total number of fruit Bessie consumes for a given papaya jungle.

    POINTS: 80

    Bessie不小心游荡出Farmer John的田地,而走进了相邻的农民的地里。她举起一个木瓜,木瓜对奶牛来说可是不可多得得美味。这个木瓜林像一般的威斯康星州的田地一样被分割成一个R行C列的网格(1 <= R <= 40, 1 <= C <= 40)。Bessie可以从一个格沿着一条跟X轴或Y轴平行的直线走到邻接的另一个格。Bessie发现一开始她自己在木瓜林的(1,1),也就是第一行第一列慢悠悠地咀嚼着木瓜。

    Bessie总是用她最信赖地双筒望远镜去数每一个邻接的格里挂着的木瓜的数目。然后她就游荡到那个有最多没有被吃掉的木瓜的邻接的格子(保证这样的格子只有一个)。

    按照这种移动方法,最终Bessie总是会在(R,C)停止然后吃掉那里的木瓜。

    给定这个木瓜林的大小及每个格的木瓜数F_ij(1 <= F_ij <= 100), 要求Bessie一共吃了多少个木瓜。

    输入输出格式

    输入格式:

     

    • Line 1: Two space-separated integers: R and C

    • Lines 2..R+1: Line i+1 describes row i of the jungle with C

    space-separated integers that tell how many fruit are in each square: F_i1, F_i2, ..., F_iC

     

    输出格式:

     

    • Line 1: A single integer that is the total number of papayas that Bessie eats by the time she finishes off the papayas at the barn in the lower right corner at coordinate (R,C).

     

    输入输出样例

    输入样例#1: 复制
    3 4 
    3 3 4 5 
    4 5 3 2 
    1 7 4 2 
    
    输出样例#1: 复制
    39 
    

    说明

    Three rows; four columns. Bessie starts in upper left corner at the '3'.

    Bessie eats the papayas in the order given by the letters next to the numbers below:

    (1,1) ---> (1,C)

    (1,1) 3a 3 4g 5h (1,C)

    | 4b 5c 3f 2i |

    (R,1) 1 7d 4e 2j (R,C)

    (R,1) ---> (R,C)

    She declines to eat 4 of the papayas but consumes 39 (visiting all but two squares of the grid).

    思路:模拟。

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,m,ans;
    int map[50][50],vis[50][50];
    void dfs(int x,int y){
        ans+=map[x][y];
        map[x][y]=0;
        if(x==n&&y==m){
            cout<<ans;
            exit(0);
        }
        int dx=map[x-1][y];
        int dy=map[x+1][y];
        int dz=map[x][y+1];
        int dc=map[x][y-1];
        if(dx>dy&&dx>dz&&dx>dc)    dfs(x-1,y);
        if(dy>dx&&dy>dz&&dy>dc)    dfs(x+1,y);
        if(dz>dy&&dz>dx&&dz>dc)    dfs(x,y+1);
        if(dc>dy&&dc>dz&&dc>dx)    dfs(x,y-1);
    }
    int main(){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        dfs(1,1);
        return 0;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    10 个最佳的网站分析方法
    网站优化:测试网站速度的8款免费工具推荐
    8 个最棒的 .NET 开发相关工具
    10 个文件和文档的比较工具
    asp.net中调用javascript自定义函数的方法(包括引入JavaScript文件)总结
    如何在ashx页面获取Session值
    java-信息安全(十一)-非对称加密算法ECC
    java-信息安全(十)-数字签名算法DSA
    java-信息安全(九)-基于DH,非对称加密,对称加密等理解HTTPS
    java-信息安全(八)-迪菲-赫尔曼(DH)密钥交换
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7840863.html
Copyright © 2020-2023  润新知