• 洛谷 P2922 [USACO08DEC]秘密消息Secret Message


    题目描述

    Bessie is leading the cows in an attempt to escape! To do this, the cows are sending secret binary messages to each other.

    Ever the clever counterspy, Farmer John has intercepted the first b_i (1 <= b_i <= 10,000) bits of each of M (1 <= M <= 50,000) of these secret binary messages.

    He has compiled a list of N (1 <= N <= 50,000) partial codewords that he thinks the cows are using. Sadly, he only knows the first c_j (1 <= c_j <= 10,000) bits of codeword j.

    For each codeword j, he wants to know how many of the intercepted messages match that codeword (i.e., for codeword j, how many times does a message and the codeword have the same initial bits). Your job is to compute this number.

    The total number of bits in the input (i.e., the sum of the b_i and the c_j) will not exceed 500,000.

    Memory Limit: 32MB

    POINTS: 270

    贝茜正在领导奶牛们逃跑.为了联络,奶牛们互相发送秘密信息.

    信息是二进制的,共有M(1≤M≤50000)条.反间谍能力很强的约翰已经部分拦截了这些信息,知道了第i条二进制信息的前bi(l《bi≤10000)位.他同时知道,奶牛使用N(1≤N≤50000)条密码.但是,他仅仅了解第J条密码的前cj(1≤cj≤10000)位.

    对于每条密码J,他想知道有多少截得的信息能够和它匹配.也就是说,有多少信息和这条密码有着相同的前缀.当然,这个前缀长度必须等于密码和那条信息长度的较小者.

    在输入文件中,位的总数(即∑Bi+∑Ci)不会超过500000.

    输入输出格式

    输入格式:

     

    • Line 1: Two integers: M and N

    • Lines 2..M+1: Line i+1 describes intercepted code i with an integer b_i followed by b_i space-separated 0's and 1's

    • Lines M+2..M+N+1: Line M+j+1 describes codeword j with an integer c_j followed by c_j space-separated 0's and 1's

     

    输出格式:

     

    • Lines 1..M: Line j: The number of messages that the jth codeword could match.

     

    输入输出样例

    输入样例#1: 复制
    4 5 
    3 0 1 0 
    1 1 
    3 1 0 0 
    3 1 1 0 
    1 0 
    1 1 
    2 0 1 
    5 0 1 0 0 1 
    2 1 1 
    
    输出样例#1: 复制
    1 
    3 
    1 
    1 
    2 
    

    说明

    Four messages; five codewords.

    The intercepted messages start with 010, 1, 100, and 110.

    The possible codewords start with 0, 1, 01, 01001, and 11.

    0 matches only 010: 1 match

    1 matches 1, 100, and 110: 3 matches

    01 matches only 010: 1 match

    01001 matches 010: 1 match

    11 matches 1 and 110: 2 matches

    思路:事实上,这个题目我要找的是

      查找比密码短或等于密码的信息

      查找比密码长的信息

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 500010
    using namespace std;
    char s[MAXN];
    int n,m,root,tot;
    int end[MAXN],sum[MAXN],tree[MAXN][3];
    int main(){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            int b;root=0;
            scanf("%d",&b);
            for(int i=1;i<=b;i++)    scanf("%c",&s[0]),scanf("%c",&s[i]);
            for(int i=1;i<=b;i++){
                int x=s[i]-'0';
                if(!tree[root][x])
                    tree[root][x]=++tot;
                sum[tree[root][x]]++;
                root=tree[root][x];
            }
            end[root]++;
        }
        for(int i=1;i<=m;i++){
            int b,flag=0,ans=0;root=0;
            scanf("%d",&b);
            for(int i=1;i<=b;i++)    scanf("%c",&s[0]),scanf("%c",&s[i]);
            for(int i=1;i<=b;i++){
                int x=s[i]-'0';
                if(!tree[root][x]){
                    flag=1;
                    break;
                }
                root=tree[root][x];
                ans+=end[root];
            }
            if(!flag)    cout<<sum[root]+ans-end[root]<<endl;
            else cout<<ans<<endl;
        }
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    js_类数组转化为数组
    js_立即执行函数
    react-router详解
    闭包_详解
    react_生命周期执行顺序
    Git-Gitlab-Genkins持续集成
    java 通用查询
    java-JDBC事务
    java中的session和cookie实现购物车的结算和清空
    servlet服务器
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7800898.html
Copyright © 2020-2023  润新知