• 洛谷 P3014 [USACO11FEB]牛线Cow Line


    题目背景

    征求翻译。如果你能提供翻译或者题意简述,请直接发讨论,感谢你的贡献。

    题目描述

    The N (1 <= N <= 20) cows conveniently numbered 1...N are playing yet another one of their crazy games with Farmer John. The cows will arrange themselves in a line and ask Farmer John what their line number is. In return, Farmer John can give them a line number and the cows must rearrange themselves into that line.

    A line number is assigned by numbering all the permutations of the line in lexicographic order.

    Consider this example:

    Farmer John has 5 cows and gives them the line number of 3.

    The permutations of the line in ascending lexicographic order: 1st: 1 2 3 4 5

    2nd: 1 2 3 5 4

    3rd: 1 2 4 3 5

    Therefore, the cows will line themselves in the cow line 1 2 4 3 5.

    The cows, in return, line themselves in the configuration '1 2 5 3 4' and ask Farmer John what their line number is.

    Continuing with the list:

    4th : 1 2 4 5 3

    5th : 1 2 5 3 4

    Farmer John can see the answer here is 5

    Farmer John and the cows would like your help to play their game. They have K (1 <= K <= 10,000) queries that they need help with. Query i has two parts: C_i will be the command, which is either 'P' or 'Q'.

    If C_i is 'P', then the second part of the query will be one integer A_i (1 <= A_i <= N!), which is a line number. This is Farmer John challenging the cows to line up in the correct cow line.

    If C_i is 'Q', then the second part of the query will be N distinct integers B_ij (1 <= B_ij <= N). This will denote a cow line. These are the cows challenging Farmer John to find their line number.

    输入输出格式

    输入格式:

     

    • Line 1: Two space-separated integers: N and K

    • Lines 2..2*K+1: Line 2*i and 2*i+1 will contain a single query.

    Line 2*i will contain just one character: 'Q' if the cows are lining up and asking Farmer John for their line number or 'P' if Farmer John gives the cows a line number.

    If the line 2*i is 'Q', then line 2*i+1 will contain N space-separated integers B_ij which represent the cow line. If the line 2*i is 'P', then line 2*i+1 will contain a single integer A_i which is the line number to solve for.

     

    输出格式:

     

    • Lines 1..K: Line i will contain the answer to query i.

    If line 2*i of the input was 'Q', then this line will contain a single integer, which is the line number of the cow line in line 2*i+1.

    If line 2*i of the input was 'P', then this line will contain N space separated integers giving the cow line of the number in line 2*i+1.

     

    输入输出样例

    输入样例#1:
    5 2 
    P 
    3 
    Q 
    1 2 5 3 4 
    
    输出样例#1:
    1 2 4 3 5 
    5 
    #include<map>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,m,vis[21];
    long long num[21];
    int main(){
        //freopen("permutation.in","r",stdin);
        //freopen("permutation.out","w",stdout);
        scanf("%d%d",&n,&m);
        for(int i=1;i<=21;i++)    num[i]=1;
        for(int i=2;i<=n;i++)    num[n-i+1]=i*num[n-i+2];
        for(int k=1;k<=m;k++){
            char c;long long x;
            cin>>c;
            memset(vis,0,sizeof(vis));
            if(c=='P'){
                cin>>x;
                long long k=x;
                int flag=1;
                for(int i=1;i<=n;i++){
                    int ans;
                    if(k>=num[i+1]){
                        long long a=k/num[i+1];
                        long long nn=k%num[i+1];
                        if(nn)    flag=1;
                        else flag=0;
                        int bns=0;
                        for(int j=1;j<=n;j++){
                            if(!vis[j])    bns++;
                            if(bns-flag==a){
                                ans=j;
                                vis[j]=1;
                                break;
                            }
                        }
                        k=nn;
                    }
                    else{
                        if(flag==1){
                            for(int j=1;j<=n;j++)
                                if(!vis[j]){
                                    ans=j;
                                    vis[j]=1;
                                    break;
                                }    
                        }
                        else{
                            for(int j=n;j>=1;j--)
                                if(!vis[j]){
                                    ans=j;
                                    vis[j]=1;
                                    break;
                                }
                        }
                    }
                    cout<<ans<<" ";
                }
                cout<<endl;
            }
            else{
                long long ans=0;
                for(int i=1;i<=n;i++){
                    cin>>x;int bns=0;
                    for(int j=1;j<=n;j++){
                        if(!vis[j])    bns++;
                        if(j==x)    break;
                    }
                    bns--;
                    vis[x]=1;
                    ans+=(long long)bns*num[i+1];
                }
                cout<<ans+1<<endl;
            }
        }
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Solr查询参数sort(排序)
    使用SolrNet访问Solr-5.5.0
    java impl
    Solr Facet 搜索时,facet.missing = true 的真正含义
    为solr增加用户验证
    每日晨读_20140705
    说说常用的服务器操作
    如何添加自定义脚本到开机自启动
    记录一个mysql连接慢的问题
    javascript时间戳和日期字符串相互转换
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7483827.html
Copyright © 2020-2023  润新知