• HDU 1258 Sum It Up


    Sum It Up

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 78   Accepted Submission(s) : 48

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

    Input

    The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

    Output

    For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

    Sample Input

    4 6 4 3 2 2 1 1
    5 3 2 1 1
    400 12 50 50 50 50 50 50 25 25 25 25 25 25
    0 0
    

    Sample Output

    Sums of 4:
    4
    3+1
    2+2
    2+1+1
    Sums of 5:
    NONE
    Sums of 400:
    50+50+50+50+50+50+25+25+25+25
    50+50+50+50+50+25+25+25+25+25+25
    #include <iostream>
    using namespace std;
    int a[21],bg[21];
    int n,T,f;
    void dfs(int i,int k,int s)
    {
        int j;int m;
        s=s+a[i];
        if(s<T)
        {
            bg[k]=a[i];
            for(j=i+1;j<=n;j++)
            {
                dfs(j,k+1,s);
                while(a[j+1]==a[j]) j++;//判重
            }
        }
        else if(s==T)
        {
            f=1;
            bg[k]=a[i];
            int o;
            if(k==1) cout<<bg[1]<<endl;
            else 
            {
                cout<<bg[1];
                for(o=2;o<=k;o++)
                {
                    cout<<'+'<<bg[o];
                }
                cout<<endl;
            }
        }
    }
    
    int main()
    {
        while(cin>>T>>n&&(n||T))
        {
            cout<<"Sums of "<<T<<':'<<endl;
            f=0;
            int i;
            for(i=1;i<=n;i++)
            {
                cin>>a[i];
            }
            for(i=1;i<=n;i++)
            {
                dfs(i,1,0);
                while(a[i+1]==a[i]) i++;//判重
            }
            if(f==0) cout<<"NONE"<<endl;
        }
        return 0;
    }



  • 相关阅读:
    Oracle: 一个很让人纠结的sql问题,给自己长个记性
    TextInfo list of CultureInfo
    一个简单的面试题称粮食
    C++ 中什么是内联函数(zhuan)
    C/C++ 到 shellcode 过程
    常量指针与指针常量的区别(转帖)
    分清函数指针和指针函数
    如何编写自己的缓冲区溢出利用程序? (zz)
    动态获取API函数地址对抗win7 aslr安全机制(转)
    暴力搜索内存空间获得 Api 的线性地址
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/8411087.html
Copyright © 2020-2023  润新知