• HDU 1241 Oil Deposits


    Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 36966    Accepted Submission(s): 21431


    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     
    Sample Input
    1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
     
    Sample Output
    0 1 2 2
     
    题目让我们求有多少块油田。
    8个方向也是@的话,就看作一块
    遍历地图,一旦发现某处有油田,就将它及附近的都变成*,然后个数++
    #include <iostream>
    using namespace std;
    char map[105][105];
    int dir[8][2] = { { -1,-1 },{ -1,0 },{ -1,1 },{ 0,-1 },{ 0,1 },{ 1,-1 },{ 1,0 },{ 1,1 } };
    int n, m, sum;
    int safe(int a, int b)
    {
        if (a <= 0 || b <= 0 || a>n || b>m) return 0;
        return 1;
    }
    void dfs(int x, int y)
    {
        int c;
        for (c = 0; c<8; c++)//八个方向遍历
        {
            if (safe(x + dir[c][0], y + dir[c][1]) && map[x + dir[c][0]][y + dir[c][1]] == '@')
            {
                map[x + dir[c][0]][y + dir[c][1]] = '*';
                dfs(x + dir[c][0], y + dir[c][1]);
            }
        }
        return;
    }
    
    
    int main()
    {
        while (cin >> n >> m)
        {
            if (n == 0 && m == 0) break;
            int i, j;
            sum = 0;
            for (i = 1; i <= n; i++)
            {
                for (j = 1; j <= m; j++)
                {
                    cin >> map[i][j];
                }
            }
            for (i = 1; i <= n; i++)//遍历地图,一旦发现某处有油田,就将附近的都变成*
            {
                for (j = 1; j <= m; j++)
                {
                    if (map[i][j] == '@')
                    {
                        map[i][j] = '*';
                        dfs(i, j); sum++;
                    }
                }
            }
            cout << sum << endl;
        }
        return 0;
    }
  • 相关阅读:
    jQuery弹出层插件大全:
    JavaScript数组去重的几种方法
    sql去除重复列(行)
    VS无法启动调试
    .将DayOfWeek转换成中文的几种方式
    关于 uniqueidentifier
    链接服务器
    我的目标:系统架构师
    异常(1)
    Visual C++开发工具与调试技巧整理
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271292.html
Copyright © 2020-2023  润新知