• HDU 1072 Nightmare


    Nightmare

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12701    Accepted Submission(s): 6199


    Problem Description
    Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

    Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

    Here are some rules:
    1. We can assume the labyrinth is a 2 array.
    2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
    3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
    4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
    5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
    6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius' start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius' target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
     
    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
     
    Sample Input
    3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
     
    Sample Output
    4 -1 13
     
    #include <iostream>
    #include <queue>
    using namespace std;
    int a[10][10];
    int b[4][2]={{1,0},{0,-1},{-1,0},{0,1}};
    int n,m;
    struct dot
    {
        int x;
        int y;
        int s;
        int t;
    };
    queue<dot> q;
    int bfs(int c,int d)
    {
        dot str,now;
        str.x=c;str.y=d;str.s=0;str.t=6;
        q.push(str);
        while(!q.empty())
        {
            now=q.front();
            q.pop();
            if(a[now.x][now.y]==3&&now.t>0) return now.s;
            if(now.t==1)  continue;//下一步没有意义,在4上要>0才能重置
            int i;
            for(i=0;i<4;i++)
            {
                int dx,dy;
                dx=now.x+b[i][0];dy=now.y+b[i][1];
                if(dx<=0||dx>n||dy<=0||dy>m||a[dx][dy]==0) continue;
                dot lat;
                if(a[dx][dy]==4)
                {
                    lat.t=6;
                    lat.x=dx;lat.y=dy;
                    lat.s=now.s+1;
                    q.push(lat);
                    a[dx][dy]=0;//炸弹用一次,否则会死循环
                }
                else 
                {
                    lat.x=dx;lat.y=dy;
                    lat.t=now.t-1;lat.s=now.s+1;
                    q.push(lat);
                }
            }
        }
        return -1;
    }
    int main()
    {
        int T;
        int ans;
        cin>>T;
        while(T--)
        {
            while(!q.empty()) q.pop();//要记得初始化队列
            ans=0;
            cin>>n>>m;
            int i,j,si,sj;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    cin>>a[i][j];
                    if(a[i][j]==2)
                    {
                        si=i;sj=j;
                    }
                }
            }
           ans=bfs(si,sj);
           cout<<ans<<endl;
        }
        
        return 0;
    }
        
    //1
    //5 8
    //1 2 1 1 0 1 4 1 
    //1 0 0 0 3 0 0 1 
    //1 4 1 0 1 1 0 1 
    //1 1 0 0 0 1 0 1 
    //1 1 1 1 1 1 1 4 
  • 相关阅读:
    AsyncTask 处理耗时操作&&显示进度条
    AutoCompleteTextView 自定义提示样式
    Android:Error:Execution failed for task ':app:clean'. > Unable to delete directory
    MaterialRefreshLayout+ListView 下拉刷新 上拉加载
    element table 表格 修改背景为透明并去除边框
    vue-element-admin 多层路由问题
    SQLServer 语句相关
    润乾报表
    v-charts
    sql 循环 ,随机数,循环插入一年数据
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271286.html
Copyright © 2020-2023  润新知