• HDU 2548 A strange lift


    A strange lift

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 29442    Accepted Submission(s): 10641


    Problem Description
    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
    Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
     
    Input
    The input consists of several test cases.,Each test case contains two lines.
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
    A single 0 indicate the end of the input.
     
    Output
    For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
     
    Sample Input
    5 1 5 3 3 1 2 5 0
     
    Sample Output
    3
     
    #include <iostream>
    #include <queue>
    using namespace std;
    int main()
    {
        int a[205];
        int v[205];
        int n,s,z;
        queue<int>q;
        while(cin>>n&&n)
        {
            int f=0;
            cin>>s>>z;
            while(!q.empty()) q.pop();
            int i;
            for(i=1;i<=n;i++)
            {
                cin>>a[i];
                v[i]=-1;
            }
            q.push(s);
            v[s]=0;
            while(!q.empty())
            {
                int x,step;
                x=q.front();q.pop();
                step=v[x];
                if(x==z) {cout<<v[x]<<endl;f=1;break;}
                if(x+a[x]<=n&&v[x+a[x]]==-1) 
                {
                    v[x+a[x]]=step+1;
                    q.push(x+a[x]);
                }
                if(x-a[x]>=1&&v[x-a[x]]==-1)
                {
                    v[x-a[x]]=step+1;
                    q.push(x-a[x]);
                }
            }
            if(!f) cout<<-1<<endl;
        }
        return 0;
    }
  • 相关阅读:
    [转]理解java的三大特性之多态
    [转]java:IO流学习小结
    Base64 加密之中文乱码
    piwik优化之定时任务生成统计数据
    php统计中英文混合的文章字数
    Linux常用命令之定时任务
    skype在线状态代码详解
    php+google/baidu翻译接口
    php限制文件下载速度的代码
    PHP破解wifi密码(wifi万能钥匙的接口)
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271276.html
Copyright © 2020-2023  润新知