• POJ 3624 Charm Bracelet(01背包模板)


    Charm Bracelet
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 45191   Accepted: 19318

    Description

    Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

    Output

    * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

    Sample Input

    4 6
    1 4
    2 6
    3 12
    2 7

    Sample Output

    23

    Source

     

    问题分析:

    N 个物品每个物品有价值v[i],重量w[i], 给定背包最大承重M,求背包能够装载的最大价值。每个物品只有放入背包和不放入背包两种选择。

    这是典型的0-1背包问题。

    代码的时间上限是O(nm), 对于每个物品i, 它所要遍历的整数区间都是[ci, m]

    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<string>
    #include<cmath>
    using namespace std;
    int dp[30000];
    int w[30000];
    int v[30000];
    int main()
    {
        int n,m;
        cin>>n>>m;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            cin>>w[i]>>v[i];
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=w[i];j--)//要倒着推过来,因为dp【j】是滚动数组
            {
                
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            }
        }
        cout<<dp[m];
        return 0;
    }
  • 相关阅读:
    开源.net 混淆器ConfuserEx介绍
    变分自编码器(Variational Autoencoder, VAE)通俗教程
    word embedding
    深度学习之自编码器AutoEncoder
    终于有人把P2P、P2C、O2O、B2C、B2B、C2C 的区别讲透了!
    强行杀windows服务
    Android快速开发系列 10个常用工具类
    判断Service是否已经启动
    Android app widget中实现跑马灯效果(非widget部件也实用)
    如何用MAT分析Android程序的内存泄露
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271044.html
Copyright © 2020-2023  润新知