• PAT 甲级 1062 Talent and Virtue (25 分)(简单,结构体排序)


    1062 Talent and Virtue (25 分)
     

    About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

    Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

    Input Specification:

    Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤), the total number of people to be ranked; L (≥), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

    Then N lines follow, each gives the information of a person in the format:

    ID_Number Virtue_Grade Talent_Grade
    

    where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

    Output Specification:

    The first line of output must give M (≤), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

    Sample Input:

    14 60 80
    10000001 64 90
    10000002 90 60
    10000011 85 80
    10000003 85 80
    10000004 80 85
    10000005 82 77
    10000006 83 76
    10000007 90 78
    10000008 75 79
    10000009 59 90
    10000010 88 45
    10000012 80 100
    10000013 90 99
    10000014 66 60
    

    Sample Output:

    12
    10000013 90 99
    10000012 80 100
    10000003 85 80
    10000011 85 80
    10000004 80 85
    10000007 90 78
    10000006 83 76
    10000005 82 77
    10000002 90 60
    10000014 66 60
    10000008 75 79
    10000001 64 90

    题意:

    ID_Number Virtue_Grade Talent_Grade
    1.只有两个分数都大于等于L才有资格排序
    2.圣人就是两个分数都大于等于H....按照总分递减
    3.君子就是才能低于H但是品德高于H...按照总分递减排序
    4.愚人就是品德和才能低于H但是品德高于才能的
    5.其余的是小人
    6.排序是按品德和才能总分递减,总分相同按照品德分递减,品德分相同按照id递减
    ————————————————
    版权声明:本文为CSDN博主「galesaur_wcy」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
    原文链接:https://blog.csdn.net/galesaur_wcy/article/details/81563516

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<string>
    #include<cstring>
    using namespace std;
    int N,L,H;
    int sa=0,no=0,fn=0,sn=0;
    struct node{
        string id;
        int vir;
        int tal;
    };
    node sage[100005];
    node noble[100005];
    node fm[100005];
    node sm[100005];
    bool cmp(node x,node y){
        if(x.vir+x.tal!=y.vir+y.tal) return x.vir+x.tal>y.vir+y.tal;
        else if(x.vir!=y.vir) return x.vir>y.vir;
        else return x.id<y.id;
    }
    int main(){
        cin>>N>>L>>H;
        for(int i=1;i<=N;i++){
            string x;
            int y,z;
            cin>>x>>y>>z;
            if(y<L||z<L) continue;
            if(y>=H&&z>=H){
                sage[++sa].id=x;
                sage[sa].vir=y;
                sage[sa].tal=z;
                continue;
            }
            if(y>=H&&z<H){
                noble[++no].id=x;
                noble[no].vir=y;
                noble[no].tal=z;
                continue;
            }
            if(y<H&&z<H&&y>=z){
                fm[++fn].id=x;
                fm[fn].vir=y;
                fm[fn].tal=z;
                continue;
            }
            sm[++sn].id=x;
            sm[sn].vir=y;
            sm[sn].tal=z;
        }
        sort(sage+1,sage+1+sa,cmp);
        sort(noble+1,noble+1+no,cmp);
        sort(fm+1,fm+1+fn,cmp);
        sort(sm+1,sm+1+sn,cmp);
        cout<<sa+no+fn+sn<<endl;
        for(int i=1;i<=sa;i++) cout<<sage[i].id<<" "<<sage[i].vir<<" "<<sage[i].tal<<endl;
        for(int i=1;i<=no;i++) cout<<noble[i].id<<" "<<noble[i].vir<<" "<<noble[i].tal<<endl;
        for(int i=1;i<=fn;i++) cout<<fm[i].id<<" "<<fm[i].vir<<" "<<fm[i].tal<<endl;
        for(int i=1;i<=sn;i++) cout<<sm[i].id<<" "<<sm[i].vir<<" "<<sm[i].tal<<endl;
        return 0;
    }
  • 相关阅读:
    C#飞行棋总结
    用python+pygame写贪吃蛇小游戏
    光线步进——RayMarching入门
    EasyX库进行图片绘制函数
    Unity复杂的旋转-欧拉角和四元数
    MATLAB GUI制作快速入门
    Three.js模型隐藏或显示
    Qt 为QPushButton、QLabel添加鼠标移入移出事件
    Unity c# 状态机的简单入门
    JavaFX Chart设置数值显示
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270629.html
Copyright © 2020-2023  润新知