• PAT 甲级 1050 String Subtraction (20 分) (简单送分,getline(cin,s)的使用)


    1050 String Subtraction (20 分)
     

    Given two strings S1​​ and S2​​, S=S1​​S2​​ is defined to be the remaining string after taking all the characters in S2​​ from S1​​. Your task is simply to calculate S1​​S2​​ for any given strings. However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case. Each case consists of two lines which gives S1​​ and S2​​, respectively. The string lengths of both strings are no more than 1. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S1​​S2​​ in one line.

    Sample Input:

    They are students.
    aeiou
    

    Sample Output:

    Thy r stdnts.

    题意:

    很简单的一道题目,除去第一个字符串中含有的第二个字符串的字符即可

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    string s1;
    string s2;
    int a[200];//标准ascii码字符集共有128个编码
    int main(){
        getline(cin,s1);
        getline(cin,s2);
        memset(a,0,sizeof(a));
        int l1,l2;
        l1=s1.size();
        l2=s2.size();
        for(int i=0;i<l2;i++){
            a[s2[i]]=1;
        }
        for(int i=0;i<l1;i++){
            if(a[s1[i]]==1) continue;
            cout<<s1[i];
        }
        return 0;
    }

    使用set

    #include<bits/stdc++.h>
    using namespace std;
    set<char>st;
    int main(){
        string s1,s2;
        getline(cin,s1);
        getline(cin,s2);
        for(int i=0;i<s2.size();i++)
            st.insert(s2[i]);
        for(int i=0;i<s1.size();i++){
            if(st.find(s1[i])==st.end())
                cout<<s1[i];
        } 
        return 0;
    }
  • 相关阅读:
    手机号码为字母或者符号(回退)
    总结:Python的赋值、深拷贝、浅拷贝有什么区别
    Python安装Mysqlclient的坑
    MySQL数据库安装和Navicat for MySQL配合使用
    chrome打开开发者工具之后看不到请求头信息——F12的使用(一)
    常见dos命令汇总
    如何编写高质量的简历-学习笔记
    windows环境搭建禅道项目管理工具
    Web接口测试工具--Jmeter
    不要把测试工具当饭吃
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11483751.html
Copyright © 2020-2023  润新知