• POJ2559 Largest Rectangle in a Histogram (单调栈


                  Largest Rectangle in a Histogram

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 26012   Accepted: 8416

    Description

    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

    Input

    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integersh1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

    Output

    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

    Sample Input

    7 2 1 4 5 1 3 3
    4 1000 1000 1000 1000
    0
    

    Sample Output

    8
    4000
    

    Hint

    Huge input, scanf is recommended.
     
    代码如下:
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<queue>
    #include<cstring>
    #include<stack>
    using namespace std;
    const int maxn = 1e5+5;
    int a[maxn];
    int s[maxn];
    int w[maxn];
    int top;
    int main(){
        int n;
        while(scanf("%d",&n),n){
            memset(a,0,sizeof(a));
            memset(s,0,sizeof(s));
            memset(w,0,sizeof(w));
            for(int i=1;i<=n;i++){
                scanf("%d",&a[i]);
            }
            int p=0;
            long long ans=0;
            a[n+1]=0;
            for(int i=1;i<=n+1;i++){
                if(a[i]>s[p]){
                    s[++p]=a[i];
                    w[p]=1;
                }else{
                    int width=0;
                    while(s[p]>a[i]){
                        width+=w[p];
                        ans=max(ans,(long long)width*s[p]);
                        p--;
                    }
                    s[++p]=a[i];
                    w[p]=width+1;
                }
            }
            cout<<ans<<endl;
        }
    }
    View Code
    每一个不曾刷题的日子 都是对生命的辜负 从弱小到强大,需要一段时间的沉淀,就是现在了 ~buerdepepeqi
  • 相关阅读:
    dedecms 权重排序问题
    HTML5学习笔记简明版(1):HTML5介绍与语法
    通过jquery 获取文本框的聚焦和失焦方法
    14种网页图片和文字特效的jQuery插件代码
    input文本框实现宽度自适应代码实例,input文本框
    html5,html5教程
    css的#和.的区别
    css style与class之间的区别,cssclass
    网页点击按钮弹出遮罩层,拖动和关闭效果
    基于CSS+dIV的网页层,点击后隐藏或显示
  • 原文地址:https://www.cnblogs.com/buerdepepeqi/p/9452942.html
Copyright © 2020-2023  润新知