• HDU1520 树形DP入门


    Anniversary party

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 15968    Accepted Submission(s): 6125


    Problem Description
    There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
     
    Input
    Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
    L K 
    It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
    0 0
     
    Output
    Output should contain the maximal sum of guests' ratings.
     
    Sample Input
    7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
     
    Sample Output
    5
     

    题意:员工的上级和员工不能一起参加聚会,每个员工都有一个权值,问怎么样使来的人权值最大

    题解:每个员工(除了大老板外)都有一个上级,这样结点有子节点,相互连接,就可以形成一个树形的结构,那么在树上想要得到最优解的时候就可以想到树形DP了

    如果上级来了,那么他的员工就不能来,很容易想到定义的状态为dp[maxn][2],其中定义1为来,0定义为不来

    转移方程:if(i来) dp[i][1]+=dp[j][0]//j是i的子节点

    else dp[i][0]+=max(dp[j][1],dp[j][0]),这里的0代表了不来,1代表了来 

    代码如下

    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    #include <iostream>
    using namespace std;
    const int maxn = 1e5+5;
    int f[maxn];
    int vis[maxn];
    int dp[maxn][2];
    int t;
    void dfs(int node){
      vis[node]=1;
      for(int i=1;i<=t;i++){
        if(!vis[i]&&f[i]==node){
          dfs(i);
          dp[node][1]+=dp[i][0];
          dp[node][0]+=max(dp[i][0],dp[i][1]);
        }
      }
    }
    int main(){
       while(cin>>t){
         for(int i=1;i<=t;i++){
           cin>>dp[i][1];
         }
         int root=0;
         int l,k;
         while(cin>>l>>k){
           if(l==0&&k==0) break;
           f[l]=k;
           root=k;
         }
         memset(vis,0,sizeof(vis));
         dfs(root);
         cout<<max(dp[root][0],dp[root][1])<<endl;
       }
    }
    View Code
     
    每一个不曾刷题的日子 都是对生命的辜负 从弱小到强大,需要一段时间的沉淀,就是现在了 ~buerdepepeqi
  • 相关阅读:
    angular2 如何使用animate实现动画效果
    angular2+ 组件中用@import进来的css不起作用
    ReentrantLock & AQS
    常用JDK命令
    分布式缓存
    持续交付
    持续部署
    持续集成
    领域驱动设计简介
    spring boot 整合JPA bean注入失败
  • 原文地址:https://www.cnblogs.com/buerdepepeqi/p/9343127.html
Copyright © 2020-2023  润新知