• 2017杭电多校第六场1011Classes


    传送门

    Classes

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 0    Accepted Submission(s): 0


    Problem Description
    The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.
    Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.
    Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.
    However, due to statistical errors, some data are wrong and these data should be ignored.
    Smart you must know how to write a program to find the maximum number of students.
     

    Input
    The first line of the input gives the number of test cases T; T test cases follow.
    Each case begins with one line with one integer N, indicates the number of class.
    Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 
    It's guaranteed that at least one data is right in each test case.

    Limits
    T100
    1N100
    0a,b,c,d,e,f,g100
     

    Output
    For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.
     

    Sample Input
    2 2 4 5 4 4 3 2 2 5 3 1 2 0 0 0 2 0 4 10 2 3 4 9 6 12 6 3 5 3 2
     

    Sample Output
    7 15
    Hint
    In the second test case, the data uploaded by Class 1 is wrong. Because we can't find a solution which satisfies the limitation. As for Class 2, we can calculate the number of students who only enrolled in course A is 2, the number of students who only enrolled in course B is 6, and nobody enrolled in course C, the number of students who only enrolled in courses A and B is 1, the number of students who only enrolled in courses B and C is 3, the number of students who only enrolled in courses A and C is 1, the number of students who enrolled in all courses is 2, so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.
     

    Statistic | Submit | Clarifications | Back


    代码如下
    #include <iostream>
    #include <string>
    #include<algorithm>
    #include<cstring>
    #include<cstdio>
    using namespace std; 
    #define ll long long
    int main()
    {
        int a, b, c, ab, bc, ac, abc;
        int t,n,ans=0;
        cin >> t;
        while (t--) {
            ans = 0;
            cin >> n;
            for (int i = 0; i < n;++i) {
                int cnt = 0;
                cin >> a >> b >> c >> ab >> bc >> ac >> abc;
                ac =ac-abc;
                bc =bc-abc;
                ab =ab-abc;
                if (ab < 0 || bc < 0 || ac < 0)
                    continue;
                a = a - ab - ac - abc;
                b = b - ab - bc - abc;
                c = c - ac - bc - abc;
                if (a < 0 || b < 0 || c < 0)
                    continue;
                cnt += a + b + c + ab + ac + bc + abc;
                ans = max(ans, cnt);
            }
            cout << ans << endl;
        }
        return 0;
    }
    


  • 相关阅读:
    Vue的基本使用
    django中的跨表查询梳理
    docker安装及配置
    大数据分析(一)探索性分析
    搜索引擎-一种提示词推荐算法
    shell变量详解
    机器学习之寻找KMeans的最优K
    大数据系统之监控系统(二)Flume的扩展
    大数据系统之监控系统(一)
    大数据系统之系统设计
  • 原文地址:https://www.cnblogs.com/bryce1010/p/9387433.html
Copyright © 2020-2023  润新知