• 2017青岛网络赛1008 Chinese Zodiac


    Chinese Zodiac

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 2451    Accepted Submission(s): 1645


    Problem Description
    The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
    Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
    If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
     

    Input
    The first line of input contains an integer T (1T1000) indicating the number of test cases.
    For each test case a line of two strings describes the signs of Victoria and her husband.
     

    Output
    For each test case output an integer in a line.
     

    Sample Input
    3 ox rooster rooster ox dragon dragon
     

    Sample Output
    8 4 12
     

    Source
    输入输出测试
     

    Statistic | Submit | Clarifications | Back


    题意:十二生肖大循环

    思路:比较水

    #include <iostream>
    #include<vector>
    #include<string>
    using namespace std;
    
    int main()
    {
        vector< string>vec;
        vec.push_back("rat");
        //vec[0].second=1;
        vec.push_back("ox");
        //vec[1].second=2;
        vec.push_back("tiger");
        //vec[2].second=3;
        vec.push_back("rabbit");
        //vec.push_back("monkey");
        vec.push_back("dragon");
        vec.push_back("snake");
        vec.push_back("horse");
        vec.push_back("sheep");
        vec.push_back("monkey");
        vec.push_back("rooster");
        vec.push_back("dog");
        vec.push_back("pig");
    
        int t;
        cin>>t;
        while(t--)
        {
            string str1,str2;
            cin>>str1>>str2;
            int cnt1,cnt2;
            for(int i=0;i<=11;i++)
            {
                if(vec[i]==str1)
                {
                    cnt1=i+1;
                    break;
                }
            }
            for(int j=0;j<=11;j++)
            {
    
                if(vec[j]==str2)
                {
                    cnt2=j+1;
                    break;
                }
            }
            if(cnt2-cnt1>0)
                cout<<cnt2-cnt1<<endl;
            else
                cout<<cnt2-cnt1+12<<endl;
        }
    }







  • 相关阅读:
    主席树套树状数组——带修区间第k大zoj2112
    卢卡斯定理——应用hdu4349
    没这5个证 付完钱房子也不是你的!
    Java transient关键字使用小记
    线性结构与非线性结构
    java事件处理机制(自定义事件)
    反射setAccessible()方法
    排序
    [JIRA] 最新Linux安装版本jira6.3.6安装破解以及数据导入的详细步骤
    深入研究java.lang.ThreadLocal类
  • 原文地址:https://www.cnblogs.com/bryce1010/p/9387212.html
Copyright © 2020-2023  润新知