• UVA


    Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

     Status

    Description

    Download as PDF
    epsfbox{p3602.eps} Figure 1.
    DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:


    ``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"


    Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.


      DNA sequence of gene X
    Cat: GCATATGGCTGTGCA
    Dog: GCAAATGGCTGTGCA
    Horse: GCTAATGGGTGTCCA
    Cow: GCAAATGGCTGTGCA
    Monkey: GCAAATCGGTGAGCA


    Figure 2. DNA sequences of gene X in five animals.


    Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,..., sm of length n , the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of S . For example, given the three strings `` AGCAT" `` AGACT" and `` GGAAT" the consensus string of the given strings is `` AGAAT" because the sum of the Hamming distances between `` AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is `` GCAAATGGCTGTGCA" and the consensus error is 7.

    Input 

    Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers m and n which are separated by a single space. The integer m(4$ le$m$ le$50) represents the number of DNA sequences and n(4$ le$n$ le$1000) represents the length of the DNA sequences, respectively. In each of the next m lines, each DNA sequence is given.

    Output 

    Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input and output for three test cases.

    Sample Input 

    3 
    5 8 
    TATGATAC 
    TAAGCTAC 
    AAAGATCC 
    TGAGATAC 
    TAAGATGT 
    4 10 
    ACGTACGTAC 
    CCGTACGTAG 
    GCGTACGTAT 
    TCGTACGTAA 
    6 10 
    ATGTTACCAT 
    AAGTTACGAT 
    AACAAAGCAA 
    AAGTTACCTT 
    AAGTTACCAA 
    TACTTACCAA
    

    Sample Output 

    TAAGATAC 
    7 
    ACGTACGTAA 
    6 
    AAGTTACCAA 
    12
    

    #include<iostream>
    #include<cstring>
    #include<string>
    #include<cstdio>
    using namespace std;
    char s[100][1005];
    
    int main()
    {
    	int casen;
    	cin >> casen;
    	while (casen--)
    	{
    		int m, n;
    		cin >> m >> n;
    		for (int i = 0; i < m; i++)
    			cin >> s[i];
    		int A, C, G, T;
    		char ans[1005];
    		
    		for (int i = 0; i < n; i++)
    		{
    			A = C = G = T = 0;
    			for (int j = 0; j < m; j++)
    			{
    				switch (s[j][i])
    				{
    				case 'A': A++; break;
    				case 'C': C++; break;
    				case 'G': G++; break;
    				case 'T': T++; break;
    				}
    			}
    			if (A >= C && A >= G && A >= T) ans[i] = 'A';
    			else if (C > A && C >= G && C >= T) ans[i] = 'C';
    			else if (G > C && G > A && G >= T) ans[i] = 'G';
    			else if (T > G && T > A && T > C) ans[i] = 'T';
    		}
    		ans[n] = '';
    		int sum = 0;
    		for (int i = 0; i < m;i++)
    		for (int j = 0; j < n;j++)
    		if (s[i][j] != ans[j])
    			sum++;
    
    		cout << ans << endl;
    		cout << sum << endl;
    	}
    }



  • 相关阅读:
    Caffe2(1)----Ubantu14.04安装
    ROS知识(16)----如何编译时自动链接同一个工作空间的其他包的头文件(包含message,srv,action自动生成的头文件)
    GIT(4)----免输入账号和密码方法
    faceNet编译问题
    Python知识(7)--最小二乘求解
    BeanShell用法汇总(部分摘抄至网络)
    web_custom_request和web_submit_data
    创建一个数组,然后随机输出一个数组的值
    lr常见问题
    通过ctrl+r快速启动程序
  • 原文地址:https://www.cnblogs.com/brucemengbm/p/6786388.html
Copyright © 2020-2023  润新知