• PAT 1013


    1013. Battle Over Cities (25)

    It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

    For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

    Input

    Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

    Output

    For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

    Sample Input
    3 2 3 
    1 2
    1 3
    1 2 3
    Sample Output
    1 
    0
    0

    层次遍历,查找图中有多少个联通的子图。注意数组mTree的使用,当mTree中的元素为-1时,表示该节点为树根,当mTree中的元素为0时,表示改点被占有,其余大于0的值表示该点的父节点。

    代码

     1 #include <stdio.h>
     2 #include <string.h>
     3 
     4 int find_num_of_tree(int,int);
     5 int map[1000][1000];
     6 int mTree[1000];
     7 int flag[1000];
     8 int queue[1000];
     9 int main()
    10 {
    11     int N,M,K;
    12     int checked;
    13     int i;
    14     int s,e;
    15     while(scanf("%d%d%d",&N,&M,&K) != EOF){
    16         memset(map,0,sizeof(map));
    17         for(i=0;i<M;++i){
    18             scanf("%d%d",&s,&e);
    19             map[s][e] = map[e][s] = 1;
    20         }
    21         for(i=0;i<K;++i){
    22             scanf("%d",&checked);
    23             printf("%d ",find_num_of_tree(N,checked)-1);
    24         }
    25     }
    26     return 0;
    27 }
    28 
    29 int find_num_of_tree(int n,int checked)
    30 {
    31     if(n < 1)
    32         return 0;
    33     int base,top;
    34     int i,j;
    35     memset(flag,0,sizeof(flag));
    36     flag[checked] = 1;
    37     for(i=1;i<=n;++i){
    38         mTree[i] = -1;
    39     }
    40     mTree[checked] = 0;
    41     for(i=1;i<=n;++i){
    42         if(flag[i])
    43             continue;
    44         queue[0] = i;
    45         base = 0;
    46         top = 1;
    47         while(base < top){
    48             int x = queue[base++];
    49             flag[x] = 1;
    50             for(j=1;j<=n;++j){
    51                 if(!flag[j] && map[x][j]){
    52                     queue[top++] = j;
    53                     mTree[j] = x;
    54                 }
    55             }
    56         }
    57     }
    58     int num = 0;
    59     for(i=1;i<=n;++i){
    60         if(mTree[i] == -1)
    61             ++num;
    62     }
    63     return num;
    64 }

  • 相关阅读:
    [EF]vs15+ef6+mysql code first方式
    Asp.net MVC]Asp.net MVC5系列——布局视图
    Asp.net MVC]Asp.net MVC5系列——Routing特性
    Asp.net MVC]Asp.net MVC5系列——Razor语法
    Asp.net MVC]Asp.net MVC5系列——实现编辑、删除与明细信息视图
    Asp.net MVC]Asp.net MVC5系列——在模型中添加验证规则
    Asp.net MVC]Asp.net MVC5系列——在模型中添加
    Django跨域(前端跨域)
    Stark组件
    Admin组件
  • 原文地址:https://www.cnblogs.com/boostable/p/pat_1013.html
Copyright © 2020-2023  润新知