• ACM-简单题之Ignatius and the Princess II——hdu1027


    转载请注明出处:http://blog.csdn.net/lttree

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4436    Accepted Submission(s): 2642


    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?
     

    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     

    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     

    Sample Input
    6 4 11 8
     

    Sample Output
    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
     

    Author
    Ignatius.L
     

    题目:http://acm.hdu.edu.cn/showproblem.php?pid=1027


    这道题,题意就是求 N的第m种排列。

    应该属于组合数学中的一种。刚好之前做过康托展开,就感觉能够用康托展开来做。

    (康拓展开详情可戳→http://blog.csdn.net/lttree/article/details/24798653

    可是,我看了看数据范围就被吓到了, N and M(1<=N<=1000, 1<=M<=10000)。

    阶乘,最多仅仅是10。怎么N能够到1000.。。。

    细致一想就能够发现,M最大为10000。也就是说。最多也就仅仅有后面8个数才会动。前面不会动的。

    由于1~8的阶乘为:1,2,6,24,120,720,5040,40320.

    8的阶乘为40320>10000  10000种以内的排列序,仅仅能在最后8个变化。

    换种说法,不管N为多少,当N>8时,前N-8是不变的。仅仅有后面8个在变化。

    比如:N为11,那么前面3个数为1 2 3顺序一定不变。变化的永远是后面4~11


    思路想出来后。解决这道题就不算太难。

    本来我用的是,边算遍输出。可是总是PE,可能还是有地方没想到吧。

    就直接将答案存在一个ans数组里。最后一起输出,就AC了。


    /****************************************
    *****************************************
    *        Author:Tree                    *
    *From :http://blog.csdn.net/lttree      *
    * Title : Ignatius and the Princess II  *
    *Source: hdu 1027                       *
    * Hint  : 康托展开                     *
    *****************************************
    ****************************************/
    
    #include <iostream>
    using namespace std;
    int fac[]={1,1,2,6,24,120,720,5040,40320};
    // 存储答案
    int ans[10001],len;
    // 康托展开的逆   n为要对几位数排序,k为第几个数,num为这n个数应该从多少開始
    void reverse_kangtuo(int n,int k,int num)
    {
        int i, j, t, vst[11]={0};
        char s[11];
    
        --k;
        for (i=0; i<n; i++)
        {
            t = k/fac[n-i-1];
            for (j=1; j<=n; j++)
                if (!vst[j])
                {
                    if (t == 0) break;
                    --t;
                }
            s[i] = '0'+j;
            vst[j] = 1;
            k %= fac[n-i-1];
        }
        // 排序后的赋给答案数组
        for(int kk=0;kk<n;++kk)
            ans[len++]=s[kk]-'1'+num;
    }
    
    int main()
    {
        int n,m;
        int i,j,temp1,temp2;
        while( cin>>n>>m )
        {
            i=1;
            len=0;
            if( n>8 )
            {
                temp1=n%8;
                temp2=(n/8-1)*8;
                // 对应答案赋值
                for(;i<=temp1;++i)
                    ans[len++]=i;
                for(j=0;j<temp2;++j,++i)
                    ans[len++]=i;
                reverse_kangtuo(8,m,i);
            }
            else    reverse_kangtuo(n,m,i);
    
            // 输出,注意最后一个数后面没有空格
            for(i=0;i<len-1;++i)
                cout<<ans[i]<<" ";
            cout<<ans[len-1]<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    深入理解 Java中的 流 (Stream)
    算法学习
    编译Opencv的GPU,利用CUDA加速
    【linux】【windows】查看你想访问的电脑Ip 和 端口是否 通畅
    【docker】centos7 上拉取docker镜像,一直拉取不到,报错:Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while w
    【mybatis】标签条件中判断入参属性值是否包含子字符串
    【java】Java多线程总结之线程安全队列Queue【转载】
    【spring boot】【redis】spring boot 集成redis的发布订阅机制
    【spring boot】spring boot 基于redis pipeline 管道,批量操作redis命令
    【java】java删除文件delete和deleteOnExit 方法的区别,为什么调用deleteOnExit无效?
  • 原文地址:https://www.cnblogs.com/blfshiye/p/5173840.html
Copyright © 2020-2023  润新知