• POJ 3176:Cow Bowling


    Cow Bowling
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 13464   Accepted: 8897

    Description

    The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

              7
    
    
    
            3   8
    
    
    
          8   1   0
    
    
    
        2   7   4   4
    
    
    
      4   5   2   6   5
    Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

    Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

    Input

    Line 1: A single integer, N 

    Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

    Output

    Line 1: The largest sum achievable using the traversal rules

    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Hint

    Explanation of the sample: 

              7
    
             *
    
            3   8
    
           *
    
          8   1   0
    
           *
    
        2   7   4   4
    
           *
    
      4   5   2   6   5
    The highest score is achievable by traversing the cows as shown above.

    简单的数塔DP问题。



    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    
    using namespace std;
    
    const int M = 350 +5;
    int Cow[M][M];
    
    int main()
    {
        int n;
        while(scanf("%d", &n)!=EOF)
        {
            memset(Cow, 0, sizeof(Cow));
            for(int i=1; i<=n; i++)
                for(int j=1; j<=i; j++)
            {
                scanf("%d", &Cow[i][j]);
            }
            for(int i=n-1; i>=1; i--)
                for(int j=1; j<=i; j++)
                Cow[i][j]+=max(Cow[i+1][j], Cow[i+1][j+1]);
            cout<<Cow[1][1]<<endl;
        }
    
        return 0;
    }
    


  • 相关阅读:
    Javascript一天学完系列(四)函数上下文bind &call
    Javascript一天学完系列(三)JavaScript面向对象
    Javascript一天学完系列(二)Callbacks回调函数
    Python(切片)
    水果篮子(母函数)
    判断链表是否有环
    链表部分逆置
    Python(List和Tuple类型)
    HDU1426(DFS)
    HDU4474(数位BFS)
  • 原文地址:https://www.cnblogs.com/blfshiye/p/5059095.html
Copyright © 2020-2023  润新知