• UVa


    Background

    Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

    The Problem

    Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent a box tex2html_wrap_inline40(length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze properties of the box such as the sum of its dimensions.

    In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes tex2html_wrap_inline44 such that each box tex2html_wrap_inline46 nests in boxtex2html_wrap_inline48 ( tex2html_wrap_inline50 .

    A box D = ( tex2html_wrap_inline52 ) nests in a box E = ( tex2html_wrap_inline54 ) if there is some rearrangement of the tex2html_wrap_inline56 such that when rearranged each dimension is less than the corresponding dimension in box E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).

    For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.

    Formally, we define nesting as follows: box D = ( tex2html_wrap_inline52 ) nests in box E = ( tex2html_wrap_inline54 ) if there is a permutation tex2html_wrap_inline62 of tex2html_wrap_inline64 such that ( tex2html_wrap_inline66 ) ``fits'' in ( tex2html_wrap_inline54 ) i.e., iftex2html_wrap_inline70 for all tex2html_wrap_inline72 .

    The Input

    The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on the same line.)

    This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The tex2html_wrap_inline82 line in the sequence ( tex2html_wrap_inline84 ) gives the measurements for the tex2html_wrap_inline82 box.

    There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of that nesting string (the number of boxes in the string).

    In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

    The Output

    For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.

    The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).

    If there is more than one longest nesting string then any one of them can be output.

    Sample Input

    5 2
    3 7
    8 10
    5 2
    9 11
    21 18
    8 6
    5 2 20 1 30 10
    23 15 7 9 11 3
    40 50 34 24 14 4
    9 10 11 12 13 14
    31 4 18 8 27 17
    44 32 13 19 41 19
    1 2 3 4 5 6
    80 37 47 18 21 9

    Sample Output

    5
    3 1 2 4 5
    4
    7 2 5 6

    动态规划。和嵌套矩形问题本质是一样的。只是这里不须要输出字典序最小的结果。

    AC代码:

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cctype>
    #include <cstring>
    #include <string>
    #include <sstream>
    #include <vector>
    #include <set>
    #include <map>
    #include <algorithm>
    #include <stack>
    #include <queue>
    #include <bitset> 
    #include <cassert> 
    #include <cmath>
    #include <functional>
    
    using namespace std;
    
    const int maxk = 35;
    int k, n, ans, target;
    int dp[maxk];
    bool first;
    
    struct Box
    {
    	int dimension[12];
    	bool operator < (const Box& rhs) const { // 方便推断是否嵌套
    		for (int i = 0; i < n; i++) {
    			if (dimension[i] >= rhs.dimension[i]) {
    				return false;
    			}
    		}
    		return true;
    	}
    }box[maxk];
    
    void init()
    {
    	memset(dp, -1, sizeof(dp));
    	first = true;
    	ans = -1;
    	cin >> n;
    	for (int i = 0; i < k; i++) {
    		for (int j = 0; j < n; j++) {
    			cin >> box[i].dimension[j];
    		}
    		sort(box[i].dimension, box[i].dimension + n);
    	}
    }
    
    int dfs(int i, const vector<int> *mp)
    {
    	int &ans = dp[i], temp;
    	if (ans != -1) {
    		return ans;
    	}
    	ans = 1;
    	for (int j = 0; j < mp[i].size(); j++) {
    		temp = dfs(mp[i][j], mp) + 1;
    		ans = max(temp, ans);
    	}
    	return ans;
    }
    
    void printAns(int i, const vector<int> *mp)
    {
    	if (first) {
    		cout << i + 1;
    		first = false;
    	}
    	else {
    		cout << ' ' << i + 1;
    	}
    	for (int j = 0; j < mp[i].size(); j++) {
    		if (dp[mp[i][j]] == dp[i] - 1) {
    			printAns(mp[i][j], mp);
    			break;
    		}
    	}
    }
    
    void solve()
    {
    	vector<int> mp[maxk];
    	for (int i = 0; i < k - 1; i++) {
    		for (int j = i + 1; j < k; j++) {
    			if (box[i] < box[j]) {
    				mp[i].push_back(j);
    			}
    			else if (box[j] < box[i]) {
    				mp[j].push_back(i);
    			}
    		}
    	}
    
    	for (int i = 0; i < k; i++) {
    		int temp = dfs(i, mp);
    		if (temp > ans) {
    			ans = temp;
    			target = i;
    		}
    	}
    	cout << ans << endl;
    	printAns(target, mp);
    	cout << endl;
    }
    
    int main()
    {
    	ios::sync_with_stdio(false);
    	while (cin >> k) {
    		init();
    		solve();
    	}
    
    	return 0;
    }



  • 相关阅读:
    MarkDowdPad 破解
    VimFaultException A specified parameter was not correct configSpec.guestId
    did not finish being created even after we waited 189 seconds or 61 attempts. And its status is downloading
    nsx-edge虚拟机抓包实践
    检查子网内存活的主机
    测试防火墙源端口
    vmware创建虚拟机不识别网卡
    ovs-qos配置
    ovs之组网实验
    openstack镜像制作
  • 原文地址:https://www.cnblogs.com/blfbuaa/p/6882585.html
Copyright © 2020-2023  润新知