• 1060 Are They Equal (25 分)


    If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

    Input Specification:

    Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100​​, and that its total digit number is less than 100.

    Output Specification:

    For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

    Note: Simple chopping is assumed without rounding.

    Sample Input 1:

    3 12300 12358.9
    

    Sample Output 1:

    YES 0.123*10^5
    

    Sample Input 2:

    3 120 128
    

    Sample Output 2:

    NO 0.120*10^3 0.128*10^3
    
    #include<cstdio>
    #include<string>
    #include<iostream>
    using namespace std;
    int n;//有效位数
    string deal(string s,int &e){
        int k=0;//s的下标
        while(s.length()>0&&s[0]=='0'){
            s.erase(s.begin());//去掉s的前导0 
        } 
        if(s[0]=='.'){
            s.erase(s.begin());//去掉前导0后是小数点,说明s是小于1的小数
            while(s.length()>0&&s[0]=='0'){
                s.erase(s.begin());//去掉小数点后非零位前的所有零
                e--;//每去掉一个零,指数e减1 
            } 
        } else{//去掉所有前导零后不是小数点,则找到后面的小数点删除 
            while(k<s.length()&&s[k]!='.'){
                k++;
                e++;//只要不碰到小数点就让指数e++ 
            }
            if(k<s.length()){//while结束后k<s.length(),说明碰到了小数点 
                s.erase(s.begin()+k);//把小数点删除 
            }
        }
        if(s.length()==0){
            e=0;//如果去掉前导零后s的长度变为0,说明这个数为0 
        }
        int num=0;
        k=0;
        string res;
        while(num<n){
            if(k<s.length())res+=s[k++];//只要还有数字,就加到res末尾
            else res+='0';//否则res末尾添加0
            num++;//精度加1 
        } 
        return res;
    }
     
    int main(){
        string s1,s2,s3,s4;
        cin>>n>>s1>>s2;
        int e1=0,e2=0;//e1,e2为s1与s2的指数
        s3=deal(s1,e1);
        s4=deal(s2,e2);
        if(s3==s4&&e1==e2){
            cout<<"YES 0."<<s3<<"*10^"<<e1<<endl;
        } else{
            cout<<"NO 0."<<s3<<"*10^"<<e1<<" 0."<<s4<<"*10^"<<e2<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JS键盘码值表
    JS入门笔记
    CSS居中的方法总结
    CSS布局模型思考
    条件、循环、函数定义、字符串操作练习
    Python输入输出练习,运算练习,turtle初步练习
    如何理解Comparator接口中的升降序?
    12个非常实用的JavaScript小技巧
    JAVA泛型知识(一)
    开窗函数简介
  • 原文地址:https://www.cnblogs.com/binanry/p/10050737.html
Copyright © 2020-2023  润新知