• poj1003 Hangover



    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00
              

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)
    import java.util.*;   
    public class Main {   
        public static void main(String[] args) {   
            Scanner cin = new Scanner(System.in);   
            String str;   
            int maxCardNum = 0;   
            while(cin.hasNext())   
            {   
                str = cin.nextLine();   
                if(str.equals("0.00"))   
                    break;   
                float len = Float.valueOf(str).floatValue();   
                maxCardNum = getCardNum(len);   
                System.out.println(maxCardNum + " card(s)");   
            }   
      
        }   
           
        private static int getCardNum(float len)   
        {   
            float value = 0;   
            int index = 2;     
            while (value < len)   
            {   
                value += 1.0/index;   
                index++;   
            }   
                   
            return index-2;   
        }   
      
    }  
  • 相关阅读:
    linux查看系统挂载磁盘
    Jenkins REST API 实例
    Python中 __init__.py的作用
    转载:Python中打开文件的方式(With open)
    利用tail -f /dev/null命令防止container启动后退出
    echo -e 命令详解
    Python排序
    Linux操作系统下删除除具体文件或目录之外的文件
    linux pam模块学习
    vsftpd服务器配置
  • 原文地址:https://www.cnblogs.com/bigjava/p/3930437.html
Copyright © 2020-2023  润新知