• UVA


    Description

    Download as PDF

    You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.

    Fortunately, there is one ``automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You're so slim that carrying you does not change the speed of any boat.

    Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the expected time to reach B from A?

    Your walking speed is always 1.

    To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is uniformly chosen from interval [0, L], and the boat is equally like to be moving left or right, if it's not precisely at the river bank.

    Input 

    There will be at most 10 test cases. Each case begins with two integers n and D, where n(0$ le$n$ le$10) is the number of rivers between A and B, D(1$ le$D$ le$1000) is the distance from A to B. Each of the following n lines describes a river with 3 integers: p, L and v (0$ le$p < D, 0 < L$ le$D, 1$ le$v$ le$100). p is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don't overlap. The last test case is followed by n = D = 0, which should not be processed.

    Output 

    For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

    Print a blank line after the output of each test case.

    Sample Input 

    1 1 
    0 1 2
    0 1 
    0 0
    

    Sample Output 

    Case 1: 1.000 
    
    Case 2: 1.000
    题意:给你A和B的距离。以及途中n条河的信息。问你从A到B的期望
    思路:我们单纯算过河时间的话,最快的是l/v,最慢的可能是3l/v,期间的时间是线性的,所以期望就是4l/2v=2l/v
    
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    #include <cstdio>
    using namespace std;
    
    int n;
    double p, l, v, d;
    
    int main() {
    	int cas = 1;
    	while (scanf("%d%lf", &n, &d) != EOF && n+d) {
    		while (n--) {
    			scanf("%lf%lf%lf", &p, &l, &v);
    			d = d - l + l * 2 / v;
    		}
    		printf("Case %d: %.3lf
    
    ", cas++, d);
    	}
    	return 0;
    }

     
  • 相关阅读:
    ubuntu 安装 systemback
    嵌入式gdb远程调试
    pecl 安装 phpredis
    Linux服务器内存池技术是如何实现的
    统一登录的几种常用设计模式
    数据库并发控制
    抽取一部分服务端做BFF(Backend For Frontend服务于前端的后端)
    干货 | 质量保障新手段,携程回归测试平台实践 原创 Sedro 携程技术 2021-01-21
    服务端绘图
    中间件技术在百度云原生测试中的应用实践 原创 路由器 百度智能化测试 今天
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/5236414.html
Copyright © 2020-2023  润新知