• 1034. Head of a Gang (30)


    题目链接:http://www.patest.cn/contests/pat-a-practise/1034

    题目:

    1034. Head of a Gang (30)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

    Name1 Name2 Time

    where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

    Output Specification:

    For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

    Sample Input 1:
    8 59
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    
    Sample Output 1:
    2
    AAA 3
    GGG 3
    
    Sample Input 2:
    8 70
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    
    Sample Output 2:
    0
    


    分析:

    须要找出是否是一个帮派。那么就要对集合进行推断,这就涉及到并查集,或者DFS。

    三个字母的名字离散化。

    这是一个技巧(刚開始我是用Map来做名字和int的映射,可是会有段错误。后来參考了资料。选择了对名字进行了离散化OK了)
    题目其中提到:"Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K.
    也就是说团伙是一个每一个人都会互相联系的团体,也就是说输入是能保证全互联的结构。
    当然。因为这句话的“related to”有歧义,假设你理解为A和B,B和C也算作A和C也related的话,那么就在后面把节点变成双向的就可以。

    AC代码:

    參考资料:http://blog.csdn.net/tiantangrenjian/article/details/19343961#cpp

    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<fstream>
    #include<map>
    #include<string>
    #include<queue>
    #include<string.h>
    using namespace std;
    //fstream fin("F://Temp/input.txt", ios::in);
    //#define cin fin
    int sum[17577];
    vector<int>V[17577];
    struct Gang{
     int name;
     int num;
     Gang(int nam,int n){ name = nam; num = n; }
    };
    vector<Gang>Ans;
    bool haveVisited[17577];
    vector<int>linkNodes;
    queue<int>Head;
    void DFS(int x){
     if (haveVisited[x])return;
     haveVisited[x] = true;
     int num = V[x].size();
     for (int i = 0; i < num; i++){
      DFS(V[x][i]);
     }
     linkNodes.push_back(x);
     return;
    }
    int hashName(const char name[]){        //将字符数组hash成整型  
     return (name[0] - 'A') * 26 * 26 + (name[1] - 'A') * 26 + name[2] - 'A';
    }
    void int_to_name(int n, char *s){        //整型转换回 字符数组  
     s[3] = '';
     s[2] = n % 26 + 'A';
     s[1] = (n / 26) % 26 + 'A';
     s[0] = n / (26 * 26) + 'A';
    }
    Gang* isGang(const vector<int> &v, int k){
     int size = v.size();
     if (size < 3)return NULL;
     int total = 0;
     int max = 0;
     int head = -1;
     for (int i = 0; i < size; i++){
      total += sum[v[i]];
      if (max < sum[v[i]]){//找到老大
       max = sum[v[i]];
       head = v[i];
      }
     }
     if (total <= 2 * k){//由于每一个节点都累加了时间,所以总时间是2倍的阈值
      return NULL;
     }
     else return new Gang(head, size);
    }
    int cmp(const Gang& aa, const Gang& bb){
     return aa.name < bb.name;
    }
    int main(void){
     int N, K;
     cin >> N >> K;
     memset(haveVisited, false, sizeof(haveVisited));//init
     memset(sum, 0, sizeof(sum));//init
     int idx = 0;
     for (int i = 0; i < N; i++){
      string a, b;
      int t;
      cin >> a >> b >> t;
      int name1 = hashName(a.c_str());
      int name2 = hashName(b.c_str());
      V[name1].push_back(name2);
    //V[name2].push_back(name1);
      sum[name1] += t;
      sum[name2] += t;
      Head.push(name1);
     }
     Gang* gang = NULL;
     while (!Head.empty()){
      linkNodes.clear();
      DFS(Head.front());
      Head.pop();
      gang = isGang(linkNodes, K);//推断是否是一个Gang
      if (gang != NULL){
       Ans.push_back(*gang);
      }
     }
     sort(Ans.begin(), Ans.end(), cmp);
     cout << Ans.size() << endl;
     char name[4];
     for (int i = 0; i < Ans.size(); i++){
      int_to_name(Ans[i].name, name);
      cout <<  name <<' '<< Ans[i].num << endl;
     }
     return 0;
    }


    截图:




    ——Apie陈小旭

  • 相关阅读:
    EXTI—外部中断/事件控制器
    启动文件讲解
    SysTick—系统定时器
    USART—串口通讯
    关于引脚复用,不得不提的GPIO_Pin_sources 和GPIO_Pin
    DMA—直接存储区访问
    【LightOJ1282】Leading and Trailing(数论)
    【LightOJ1336】Sigma Function(数论)
    【LightOJ1370】Bi-shoe and Phi-shoe(欧拉函数)
    【BZOJ2440】完全平方数(二分答案,莫比乌斯反演)
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/5172098.html
Copyright © 2020-2023  润新知