• POJ2828 Buy Tickets 【线段树】+【单点更新】+【逆序】


    Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 12296   Accepted: 6071

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about?

    That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    Source



    相同的代码,选择不同的编译器执行时间直接是倍数关系。

    Run ID User Problem Result Memory Time Language Code Length Submit Time
    13039660 changmu 2828 Accepted 4536K 1375MS C++ 953B 2014-07-08 00:09:31
    13039659 changmu 2828 Accepted 4764K 3391MS G++ 953B 2014-07-08 00:08:47

    这题折腾了好久。线段树节点保存的是区间空余线段的数量,因为区间是右开的,所以也能够看作是左端点空暇数量,update函数确定插入区间并更新空暇元素数量(即线段树节点的值),最关键的是在读取完节点后须要逆序插入。比方逆序读取pos, val后说明该点须要插入的位置前面有pos个空位。缕清思路后就该coding了~~

    #include <stdio.h>
    #define maxn 200002
    #define lson l, mid, rt << 1
    #define rson mid, r, rt << 1 | 1
    
    struct Node{
    	int pos, val;
    } arr[maxn];
    int tree[maxn << 2], ans[maxn];
    
    void build(int l, int r, int rt)
    {
    	tree[rt] = r - l;
    	if(tree[rt] == 1) return;
    	
    	int mid = (l + r) >> 1;
    	build(lson);
    	build(rson);
    }
    
    void update(int pos, int val, int l, int r, int rt)
    {
    	--tree[rt];
    	if(r - l == 1){
    		ans[l] = val; return;
    	}
    	
    	int mid = (l + r) >> 1;
    	if(tree[rt << 1] > pos) update(pos, val, lson);
    	else update(pos - tree[rt << 1], val, rson);
    }
    
    int main()
    {
    	int n, pos, val, i;
    	while(scanf("%d", &n) == 1){
    		for(i = 0; i < n; ++i)
    			scanf("%d%d", &arr[i].pos, &arr[i].val);
    			
    		build(0, n, 1); //注意右端点。线段树存储的是线段信息
    		
    		for(i = n - 1; i >= 0; --i)
    			update(arr[i].pos, arr[i].val, 0, n, 1);
    			
    		for(i = 0; i < n; ++i)
    			printf("%d%c", ans[i], i != (n - 1) ? ' ' : '
    ');
    		
    	}
    	return 0;
    }


  • 相关阅读:
    安装DotNetCore.1.0.1-VS2015Tools.Preview2.0.2出现0x80072f8a未指定的错误
    [迷宫中的算法实践]迷宫生成算法——Prim算法
    [MVC学习笔记]7.使用极验验证来制作更高逼格的验证码
    Android UI--提高Android UI体验
    Genymotion的使用 -- A Faster Android Emulator
    【Xamarin】Visual Studio 2013 Xamarin for Android开发环境搭建与配置&Genymotion
    【ASP.NET Web API2】利用HttpClient调用Web API(TODO)
    VMware 11 安装 Mac OS X10.10
    ASP.NET MVC 缓存Outputcache (局部动态)
    【ASP.NET Web API2】初识Web API
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/5162670.html
Copyright © 2020-2023  润新知