• UVA


    Description

    Download as PDF


      Count the Trees 

    Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.

    Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

    For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.


    egin{picture}(400,90)(50,0)put(115,62){A}put(75,10){B}put(120,60){vecto......}}put(365,62){B}put(405,10){A}put(370,60){vector(1,-1){40}}end{picture}

    If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

    Input 

    The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 300 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.

    Output 

    For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.

    Sample Input 

    1
    2
    10
    25
    0
    

    Sample Output 

    1
    4
    60949324800
    75414671852339208296275849248768000000
    

    题意:卡特兰数

    思路:JAVA练手

    import java.math.BigInteger;
    import java.util.*;
    import java.io.*;
    
    /**
     * Created by acer on 14-8-7.
     */
    public class Main {
    	public static void main(String[] args) {
    		Scanner cin = new Scanner(System.in);
    		BigInteger[] catalan = new BigInteger[301], fact = new BigInteger[601];
    		int n;
    		fact[0] = BigInteger.ONE;
    		for (int i = 1; i <= 600; i++)
    			fact[i] = fact[i-1].multiply(BigInteger.valueOf(i));
    		for (int i = 0; i <= 300; i++)
    			catalan[i] = fact[i*2].divide(fact[i+1]).divide(fact[i]);
    		while ((n = cin.nextInt()) != 0)
    			System.out.println(catalan[n].multiply(fact[n]));
    	}
    }



    版权声明:本文博主原创文章,博客,未经同意不得转载。

  • 相关阅读:
    简单封装万维易源(showapi)ip归属地查询接口
    修改七牛上传域名
    深度探索C++对象模型 个人总结 第四章 Function语意学
    深度探索C++对象模型 个人总结 第三章 Data语意学
    深度探索C++对象模型 个人总结 第二章 构造函数语意学
    深度探索C++对象模型 个人总结 第一章 关于对象
    《More Effective C++》 个人总结
    《Effective C++》个人总结
    C++ Primer第5版 第十九章课后练习答案
    C++ Primer第5版 第十八章课后练习答案
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/4832239.html
Copyright © 2020-2023  润新知