• 最大ASCII的和问题


    问题:One day when you are going to clear all your browsing history, you come up with an idea: You want to figure out what your most valued site is. Every site is given a value which equals to the sum of ASCII values of all characters in the URL. For example aa.cc has value of 438 because 438 = 97 + 97 + 46 + 99 + 99. You just need to print the largest value amongst all values of sites.
    Things are simplified because you found that all entries in your browsing history are of the following format: [domain], where [domain] consists of lower-case Latin letters and “.” only. See the sample input for more details.
     
    Input
    There are several test cases.
    For each test case, the first line contains an integer n (1 ≤ n ≤ 100), the number of entries in your browsing history.
    Then follows n lines, each consisting of one URL whose length will not exceed 100.
    Input is terminated by EOF.
     
    Output
    For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a number indicating the desired answer.
     
    Sample Input
    1
    aa.cc
    2
    www.google.com
    www.wikipedia.org

    Sample Output
    Case 1: 438
    Case 2: 1728

    回答:题意就是给n个字符串,求最大ASCII码和。

    #include <stdio.h>
    #include <string.h>

    int main() {
        int n, t = 0;
        while(scanf("%d", &n)!=EOF) {
            int maxx = 0;
            while(n--) {
                int i, tmp = 0;
                char s[105];
                scanf("%s", s);
                for(i = 0; s[i]; i++)
                    tmp += s[i];
                if(tmp > maxx)
                    maxx = tmp;
            }
            printf("Case %d: %d ", ++t, maxx);
        }
        return 0;
    }

  • 相关阅读:
    memcache概念浅谈及名称混乱之区分
    apache设置头
    Apache中关于页面缓存的设置
    memcahced&redis命令行cmd下的操作
    memcache命令行
    Memcached管理与监控
    memcache stats命令详解
    memcache基础知识-stats参数
    ab测试
    yum安装Apache,Mysql,PHP
  • 原文地址:https://www.cnblogs.com/benchao/p/4639632.html
Copyright © 2020-2023  润新知