• 求一个数阶乘后位数问题


    问题:In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
     
    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
     
    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.
     
    Sample Input
    2
    10
    20

    Sample Output
    7
    19

    回答:题意求一个数阶乘的位数.

    方法一:

    #include <stdio.h>
    #include <math.h>
    void main()
    {
     int count,var,j;
     double sum;
     scanf("%d",&count);
     while(count--)
     {
      sum=0;
      scanf("%d",&var);
      for(j=1;j<=var;j++)
       sum+=log10(j);
      printf("%d/n",(int)sum+1);
     }
    }
    这是最简单的方法,但是耗时长,406ms。
    好吧!我们换个方法:
    这需要组合数学的知识。log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e)
     方法二:
    #include <iostream>
    #include <cmath>
    #define PI 3.14159265
    int n;
    int num,ans;
    void solve()
    {
        double t;
        int i;
        t = (num*log(num) - num + 0.5*log(2*num*PI))/log(10);
        ans = t+1;
        printf("%d/n",ans);
    }
    int main()
    {
        while(scanf("%d",&n)!=EOF)
        {
            while(n--)
            {
                scanf("%d",&num);
                solve();
            }
        }
        return 0;
    }

  • 相关阅读:
    禁止鼠标多次点击选中div中的文字
    深入浅出 Nodejs 学习笔记 1
    svn 树冲突
    nodejs 按行读取 readline
    git版本控制器的基本使用
    规范javascript书写
    media query
    软件工程
    The sixth day
    The fifth day
  • 原文地址:https://www.cnblogs.com/benchao/p/4529635.html
Copyright © 2020-2023  润新知