成绩转换
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38450 Accepted Submission(s): 16816
Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
Input
输入数据有多组,每组占一行,由一个整数组成。
Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
Sample Input
56
67
100
123
Sample Output
E
D
A
Score is error!
1 import java.util.Scanner; 2 public class Main{ 3 public static void main(String[] args) { 4 Scanner scan = new Scanner(System.in); 5 int n; 6 while(scan.hasNextInt()){ 7 n = scan.nextInt(); 8 if(n<0||n>100) 9 System.out.println("Score is error!"); 10 else 11 switch(n/10){ 12 case 10: 13 case 9:System.out.println("A");break; 14 case 8:System.out.println("B");break; 15 case 7:System.out.println("C");break; 16 case 6:System.out.println("D");break; 17 default:System.out.println("E"); 18 } 19 } 20 } 21 }