• 浙江大学PAT上机题解析之1011. World Cup Betting (20)


    1011. World Cup Betting (20)

    时间限制 
    400 ms
    内存限制 
    32000 kB
    代码长度限制 
    16000 B
    判题程序   
    Standard
    作者   
    CHEN, Yue

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa.  Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game.  The rule of winning was simple: first select any three of the games.  Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose.  There was an odd assigned to each result.  The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game.  If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case.  Each case contains the betting information of 3 games.  Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places.  The characters and the number must be separated by one space.

    Sample Input
    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    
    Sample Output
    T T W 37.98
    
     
    #include <iostream>
    #include <string.h>
    
    #include <vector>
    
    #include <algorithm>
    #include <iomanip>
    
    using namespace std;
    
    typedef  struct  Bet
    {
    	float  W;
    	float  T;
    	float  L;
    }Bet;
    
    
    
    
    int main()
    {
    
    	Bet bet;
    	
    	float product=1.00000000;
    	vector<Bet>  vec;
    	vector<Bet>::iterator  it;
    	vector<string> vecStr;
    	string  temp;
    	while(cin>>bet.W>>bet.T>>bet.L)
    	vec.push_back(bet);
    
    	 for (it=vec.begin();it!=vec.end();it++)
    	 {
    
    
    		 float a = (*it).L>(*it).T?(temp="L",(*it).L):(temp="T",(*it).T);
    		 float b = a>(*it).W?a:(temp="W",(*it).W);
    		  
    		 product = product * b;
    
    		 vecStr.push_back(temp);
    	 }
    
    	 product = (product*0.65-1.0)*2.0;
    
    
    
    	 for (vector<string>::iterator it=vecStr.begin();it!=vecStr.end();it++)
    		cout<<(*it)<<" ";
    
    	 cout<<fixed<<setprecision(2)<<product<<endl;
    	    
    
    
      // system("pause");
    	return 0;
    }
    
    
    
  • 相关阅读:
    js调试工具Console命令详解
    tomcat如何正确的开启远程调试功能
    Cleanup failed to process the following paths错误的解决
    MySQL查看SQL语句执行效率
    MYSQL 的静态表和动态表的区别, MYISAM 和 INNODB 的区别
    JAX-RS之queryparam、PathParam、DefaultValue、FormParam、Context、RestController等
    C语言中的printf函数的输入输出问题
    leetcode 21.Merge Two Sorted Lists ,java
    初识C++ 中的STL
    leetcode 58.Length of Last Word
  • 原文地址:https://www.cnblogs.com/bbsno1/p/3260386.html
Copyright © 2020-2023  润新知