• 最小生成树


    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28
    //Memory Time 
    //300K   32MS 
    
    #include<iostream>
    using namespace std;
    
    const int inf=100001;      //无限大
    
    int n;   //农场数量
    int dist[101][101];
    
    int prim(void)
    {
        int s=1;
        int m=1;
        bool u[101]={false};
        u[s]=true;
    
        int min_w;
        int prim_w=0;
        int point;
        int low_dis[101];
    
        /*Initial*/
    
        for(int i=1;i<=n;i++)
            low_dis[i]=inf;
    
        /*Prim Algorithm*/
    
        while(true)
        {
            if(m==n)
                break;
    
            min_w=inf;
            for(int i=2;i<=n;i++)
            {
                if(!u[i] && low_dis[i]>dist[s][i])
                    low_dis[i] = dist[s][i];
                if(!u[i] && min_w>low_dis[i])
                {
                    min_w = low_dis[i];
                    point=i;
                }
            }
            s=point;
            u[s]=true;
            prim_w+=min_w;
            m++;
        }
        return prim_w;
    }
    
    int main(void)
    {
        while(cin>>n)
        {
            /*Input*/
    
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    cin>>dist[i][j];
    
            /*Prim Algorithm & Output*/
    
            cout<<prim()<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    TCP协议-如何保证传输可靠性
    计算机网络基础(未完待续)
    计算机理论基础
    计算机网络
    操作系统与计算机网络
    Linux系统中的vi/vim指令【详解】
    Linux面试笔试题带答案【详解】
    关于梦想(五)
    Jmeter的安装教程【图文】
    关于梦想(四)
  • 原文地址:https://www.cnblogs.com/baoluqi/p/3745690.html
Copyright © 2020-2023  润新知